summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-11-20 09:17:41 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-23 15:11:23 +0200
commitdb8cfbbd88169c695d428b89cb2baa8315208ab9 (patch)
treee9a8d8dd70a4c873c7496afd1a556305521eacad /net-misc
parentapp-admin/passwordsafe: remove old versions (diff)
downloadgentoo-db8cfbbd88169c695d428b89cb2baa8315208ab9.tar.gz
gentoo-db8cfbbd88169c695d428b89cb2baa8315208ab9.tar.bz2
gentoo-db8cfbbd88169c695d428b89cb2baa8315208ab9.zip
net-misc/gallery-dl: bump python compat; bump to 1.15.3
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/18333 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild2
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.3.ebuild45
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild2
4 files changed, 48 insertions, 2 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 578868670e1b..abb92a5e3eef 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1 +1,2 @@
DIST gallery-dl-1.15.2.tar.gz 323739 BLAKE2B 99a06331bd7dc6ec951749129ad0ac797d9ce2d9f98e75a29198fd47d0481c43b96922ea08149abfe990e8994a19b3170853618de9b51465264d100dba777f32 SHA512 7f31c0485d9de6eaf76e7b0772e66049f9aa8fd7d77d3ef6fd2803d7ec7dddbf3419051c9d8b3984eb86a8fbbf9a168cf8ec69a55082a38e2ca23cfc3574b1f4
+DIST gallery-dl-1.15.3.tar.gz 325926 BLAKE2B 9ae31ba89a60460cd041fe9f353d4a7d1dab14fe63a8967f1a94f8d0ea42ef30032e5f734cbb370f5ac681f9274ba756a156acc7bd11ca4b5aad387fdc6be76f SHA512 618dc26ba74274c961cce1ef058fce3e12741366329ce50d09421245987a88a796be3f1a31926e8b2c33cc87cddcde3585f74f4f1a80347153c2a7a9cab7e3c0
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
index e676807a0eaf..458d0edf5edc 100644
--- a/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=(python3_{7,8})
+PYTHON_COMPAT=(python3_{7..9})
PYTHON_REQ_USE="sqlite,ssl,xml"
DISTUTILS_USE_SETUPTOOLS=rdepend
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild
new file mode 100644
index 000000000000..458d0edf5edc
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index e676807a0eaf..458d0edf5edc 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=(python3_{7,8})
+PYTHON_COMPAT=(python3_{7..9})
PYTHON_REQ_USE="sqlite,ssl,xml"
DISTUTILS_USE_SETUPTOOLS=rdepend