summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-03-19 10:19:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-03-19 10:19:27 -0500
commitdc4778b8b1efc0516ad6454a34ad2ded4e0fd554 (patch)
tree90471bb906e192f039008c6a60a670016f2fcb90 /net-misc
parentnet-misc/spice-gtk: enable USE=+gtk3 per default (diff)
downloadgentoo-dc4778b8b1efc0516ad6454a34ad2ded4e0fd554.tar.gz
gentoo-dc4778b8b1efc0516ad6454a34ad2ded4e0fd554.tar.bz2
gentoo-dc4778b8b1efc0516ad6454a34ad2ded4e0fd554.zip
net-misc/spice-gtk: update live ebuild
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index 6dcfc676df85..d489cfc08da7 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -15,7 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice-gtk.git"
KEYWORDS=""
-IUSE="dbus gstaudio gstvideo gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
+IUSE="dbus gstaudio gstvideo +gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
REQUIRED_USE="?? ( pulseaudio gstaudio )"
@@ -37,7 +37,6 @@ RDEPEND="
media-libs/gst-plugins-good:1.0
)
>=x11-libs/pixman-0.17.7
- >=media-libs/celt-0.5.1.1:0.5.1
media-libs/opus
gtk3? ( x11-libs/gtk+:3[introspection?] )
>=dev-libs/glib-2.36:2
@@ -102,25 +101,26 @@ src_configure() {
fi
myconf="
- --disable-maintainer-mode \
- $(use_enable static-libs static) \
- $(use_enable introspection) \
- $(use_with sasl) \
- $(use_enable smartcard) \
- $(use_enable usbredir) \
- $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
- $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
- $(use_with gtk3 gtk 3.0) \
- $(use_enable policykit polkit) \
- $(use_enable pulseaudio pulse) \
- $(use_enable gstaudio) \
- $(use_enable gstvideo) \
- $(use_enable mjpeg builtin-mjpeg) \
- $(use_enable vala) \
- $(use_enable webdav) \
- $(use_enable dbus) \
- --disable-gtk-doc \
- --disable-werror \
+ $(use_enable static-libs static)
+ $(use_enable introspection)
+ $(use_with sasl)
+ $(use_enable smartcard)
+ $(use_enable usbredir)
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids)
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec)
+ $(use_with gtk3 gtk 3.0)
+ $(use_enable policykit polkit)
+ $(use_enable pulseaudio pulse)
+ $(use_enable gstaudio)
+ $(use_enable gstvideo)
+ $(use_enable mjpeg builtin-mjpeg)
+ $(use_enable vala)
+ $(use_enable webdav)
+ $(use_enable dbus)
+ --disable-celt051
+ --disable-gtk-doc
+ --disable-maintainer-mode
+ --disable-werror
--enable-pie"
econf ${myconf}