summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-28 08:36:10 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-28 08:42:00 +0200
commite0631b4bb8dffa5c8a17b3e87c679767ba24593b (patch)
tree8acd990af0fe88ea0f0208e502293634d0120124 /net-misc
parentdev-util/jenkins-bin: add 2.235.3 (diff)
downloadgentoo-e0631b4bb8dffa5c8a17b3e87c679767ba24593b.tar.gz
gentoo-e0631b4bb8dffa5c8a17b3e87c679767ba24593b.tar.bz2
gentoo-e0631b4bb8dffa5c8a17b3e87c679767ba24593b.zip
net-misc/rsync: Bump to version 3.2.3_pre1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/Manifest1
-rw-r--r--net-misc/rsync/rsync-3.2.3_pre1.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index 9c10729cba62..df750ec7dc7a 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1,3 +1,4 @@
DIST rsync-3.2.0.tar.gz 1048009 BLAKE2B 641be077a88958a09b083fd9658ae7f40ce3565bee1959f0c7ef82c61356a070e7ca1e0ceeb96b7a1b31a5ee031a84733ade3965aaa93f9e18795df16a6c1460 SHA512 01a109e1e061bb7f4734b694e1f15a83efdd8fcb1995e5eeea75a8d245eead4412c09b37b0fcdfe522e368673768e4fa5ed8891ccf3ae42f60293e4e68d506c2
DIST rsync-3.2.1.tar.gz 1051665 BLAKE2B de1ee047b9a378cd16fceb188d0a2e14e78751c8295263e183888b464ced9263be600bbb04b7793d48e7aa1fd2ab0709d717234f346cc6a5a028c3daddcb019e SHA512 80d639ab56a993de8016115fe15794bb9aa7012e4a8300402954760566a821c230af9dcdb19143d70663497a830289212ce329fb0c4fd5c4b6f392d850e5fd8c
DIST rsync-3.2.2.tar.gz 1057001 BLAKE2B 177a3145303ab7ed296b9233160ca4907c6b284160f4d0d15aeefd7e28009c1ea29fb3632ab57c008f0aad2f6774185cba86d2d0d68f30737fef217bd9fff402 SHA512 78107cf423e9259a7f7e9bf5527a956b648107aba72ea88b4267ae6334539342501d3c060efbc87235563b0253a12c382c4bb1f73335e68a62ff53aa905f9169
+DIST rsync-3.2.3pre1.tar.gz 1074550 BLAKE2B 37ed2626489559758f96bc5c316e5f7d439fb2021d86682b0239dca63e16b236c3a9f90fa69637c1f4c5cdcc2c174202c525c5aa7482284779af0f9b81eab157 SHA512 d9cad88dfd2e5078ebdb337a3a6c6515820c117c3c3fc782f2daa33e50270694660cfa5e2288d32de9fee25d92f19306e33d4bc25e9438894441f8e08cdf33d5
diff --git a/net-misc/rsync/rsync-3.2.3_pre1.ebuild b/net-misc/rsync/rsync-3.2.3_pre1.ebuild
new file mode 100644
index 000000000000..fb78f513976f
--- /dev/null
+++ b/net-misc/rsync/rsync-3.2.3_pre1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic prefix systemd
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="https://rsync.samba.org/"
+if [[ "${PV}" == *9999 ]] ; then
+ PYTHON_COMPAT=( python3_{6,7,8} )
+ inherit autotools git-r3 python-any-r1
+ EGIT_REPO_URI="https://github.com/WayneD/rsync.git"
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_DIR="src-previews"
+ else
+ SRC_DIR="src"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ fi
+ SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz"
+ S="${WORKDIR}/${P/_/}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE_CPU_FLAGS_X86=" sse2"
+IUSE="acl examples iconv ipv6 libressl lz4 ssl static stunnel system-zlib xattr xxhash zstd"
+IUSE+=" ${IUSE_CPU_FLAGS_X86// / cpu_flags_x86_}"
+
+LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )
+ lz4? ( app-arch/lz4[static-libs(+)] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+ )
+ system-zlib? ( sys-libs/zlib[static-libs(+)] )
+ xattr? ( kernel_linux? ( sys-apps/attr[static-libs(+)] ) )
+ xxhash? ( dev-libs/xxhash[static-libs(+)] )
+ zstd? ( app-arch/zstd[static-libs(+)] )
+ >=dev-libs/popt-1.5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+if [[ "${PV}" == *9999 ]] ; then
+ BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ ')"
+fi
+
+# Only required for live ebuild
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ if [[ "${PV}" == *9999 ]] ; then
+ eaclocal -I m4
+ eautoconf -o configure.sh
+ eautoheader && touch config.h.in
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+ --without-included-popt
+ $(use_enable acl acl-support)
+ $(use_enable iconv)
+ $(use_enable ipv6)
+ $(use_enable lz4)
+ $(use_enable ssl openssl)
+ $(use_with !system-zlib included-zlib)
+ $(use_enable xattr xattr-support)
+ $(use_enable xxhash)
+ $(use_enable zstd)
+ )
+
+ if use elibc_glibc && [[ "${ARCH}" == "amd64" ]] ; then
+ # SIMD is only available for x86_64 right now
+ # and only on glibc (#728868)
+ myeconfargs+=( $(use_enable cpu_flags_x86_sse2 simd) )
+ else
+ myeconfargs+=( --disable-simd )
+ fi
+
+ econf "${myeconfargs[@]}"
+ [[ "${PV}" == *9999 ]] || touch proto.h-tstamp #421625
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
+
+ dodoc NEWS.md README.md TODO tech_report.tex
+
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install stunnel helpers
+ if use stunnel ; then
+ emake DESTDIR="${D}" install-ssl-daemon
+ fi
+
+ # Install the useful contrib scripts
+ if use examples ; then
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
+ fi
+
+ eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
+
+ systemd_dounit "${FILESDIR}/rsyncd.service"
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+ if use stunnel ; then
+ einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
+ einfo
+ einfo "You maybe have to update the certificates configured in"
+ einfo "${EROOT}/etc/stunnel/rsync.conf"
+ fi
+ if use system-zlib ; then
+ ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
+ ewarn "using the --compress option."
+ ewarn
+ ewarn "When syncing with >=rsync-3.1.1 built with bundled zlib,"
+ ewarn "and the --compress option, add --new-compress (-zz)."
+ ewarn
+ ewarn "For syncing the portage tree, add:"
+ ewarn "PORTAGE_RSYNC_EXTRA_OPTS=\"--new-compress\" to make.conf"
+ fi
+}