summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-05-10 10:52:01 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-05-10 10:54:10 +0200
commitea6ad8e10c8f9693c6ed2d9f54b1aed490a1e677 (patch)
tree476e96d743ffa75a4bad94ed4d82e51cf881d3ec /net-misc
parentdev-libs/libyaml: add doxygen dep for building docs (diff)
downloadgentoo-ea6ad8e10c8f9693c6ed2d9f54b1aed490a1e677.tar.gz
gentoo-ea6ad8e10c8f9693c6ed2d9f54b1aed490a1e677.tar.bz2
gentoo-ea6ad8e10c8f9693c6ed2d9f54b1aed490a1e677.zip
net-misc/istioctl: Version bump to 1.1.6
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/istioctl/Manifest1
-rw-r--r--net-misc/istioctl/istioctl-1.1.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/istioctl/Manifest b/net-misc/istioctl/Manifest
index 2a4cf6b07f89..c5d204c0e1e4 100644
--- a/net-misc/istioctl/Manifest
+++ b/net-misc/istioctl/Manifest
@@ -1,3 +1,4 @@
DIST istioctl-1.0.2.tar.gz 18828091 BLAKE2B 064e9ad8b2629809c7b55514ad0a537bae8785bfebabea610a54ead0a0e665cdc718218376e07dcf5e235f8674bdd9e2eaa7a79bfd5d5485a5ddc841e1c52527 SHA512 d444dd8e0676ac9b36dc3901595f15d6504991619a82057f924141f752d2a45866df9ca388d6c63e1fbe43be4d4156f3efc748be59b565f865a0c5b3d02bda07
DIST istioctl-1.1.2.tar.gz 20682375 BLAKE2B bf0da863cade30baeceddcdaa358bce561a1848d018bd31890b2f0fb01e4ac908ca5da8d09a433fefae43c959c1aecba198ffd341c2c1f31de7a575abca973bb SHA512 6f9533f76b1847742198d48bed8fc2b0e288180d4033faf89857eb525c4d956f279a823c13196dd23fd9e46ab4261f9ff31746ac232e19530268d43cfdbaa083
DIST istioctl-1.1.4.tar.gz 20705247 BLAKE2B d3727dafcfa8a630a02040fe452a3a2b6c89d4dc2ede4128b9906adf21d97e68f8b126783d248239416a459357bee72ca0f2af19a6d34039ad59b3ade6f3b6d1 SHA512 e866fcad482ef605e4126fffe421eff7fbc1733e5d949e2ebe846f790d8825bb79d5360fe48d29913f0b015c15bc1aac224ac9f39e4e7d5948f2dcd5042570a8
+DIST istioctl-1.1.6.tar.gz 20707819 BLAKE2B 0ebd34873e6ff1fec2413afed8b4fe80baee8e9bec55bc2fab15b25266b404fb05fce6bfd0e122c5eb3fa661f5633a431aaa3042ad6d12caf2c4feb58bdbaa5e SHA512 62b9b96547af6f8050f934e4d620ab1990afc805c0abbdbc7933220d28676542222b4452f8207dbe5976116bfe8ae557ee7545e1859b0ab22d9c0c2510950fca
diff --git a/net-misc/istioctl/istioctl-1.1.6.ebuild b/net-misc/istioctl/istioctl-1.1.6.ebuild
new file mode 100644
index 000000000000..3242c5558275
--- /dev/null
+++ b/net-misc/istioctl/istioctl-1.1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="04850e14d38a69a38c16c800e237b1108056513e"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+ istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+ istio.io/istio/pkg/version.buildStatus=Clean" \
+ VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+ popd || die
+}
+
+src_install() {
+ dobin out/linux_amd64/release/${PN}
+ pushd "src/${EGO_PN}" || die
+ dodoc README.md
+}