summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2020-11-06 19:10:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-12 10:30:57 +0200
commitf61be1c34928d1191d1d5031fe8a5b752769f1e4 (patch)
treef586b3b55237cd2d4f7ce23a95c7538d5a0fe4ce /net-misc
parentdev-libs/efl: update to lua-single on lua'd efl (diff)
downloadgentoo-f61be1c34928d1191d1d5031fe8a5b752769f1e4.tar.gz
gentoo-f61be1c34928d1191d1d5031fe8a5b752769f1e4.tar.bz2
gentoo-f61be1c34928d1191d1d5031fe8a5b752769f1e4.zip
net-misc/seafile: version bump to 7.0.10
Closes: https://bugs.gentoo.org/753317 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/seafile/Manifest1
-rw-r--r--net-misc/seafile/seafile-7.0.10.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/seafile/Manifest b/net-misc/seafile/Manifest
index db48d735acd3..284ee172adde 100644
--- a/net-misc/seafile/Manifest
+++ b/net-misc/seafile/Manifest
@@ -1 +1,2 @@
+DIST seafile-7.0.10.tar.gz 707294 BLAKE2B 7f31d09480a7be09c957a79442bc0c952a4b3802fe17d660cb4ae7d157fcb656280751ed5033e399a705fc24c8b0a232e55e5f289792bdb69abec304c85d3473 SHA512 6c5870e75d52f4409fc6f7e3884d3e9208693997b25a6347980a8d164ec6a3348f4b3f5a532f11b9221822aa0ec9125b9d9af8ba7abc4d392cd5b5f602df9289
DIST seafile-7.0.9.tar.gz 706859 BLAKE2B 2cbd12bfdda9c2cc13d38233a56d0d2f52ad04e03bd14c90c6ff086756fb7ab4f63319906030f9a5f4ec2625dbe23b2892c069f2b5d50c6997b23deaf2cb61d7 SHA512 4c87e7a4a6a4cef631cbfbeb1bde3c8c9e0915d5fe4597d5b3a4b8aa15e9650e97b51ee6a3b0bae4d235ec53149dca01aed7acd704da593c97da0a17e352a75d
diff --git a/net-misc/seafile/seafile-7.0.10.ebuild b/net-misc/seafile/seafile-7.0.10.ebuild
new file mode 100644
index 000000000000..5528c543809f
--- /dev/null
+++ b/net-misc/seafile/seafile-7.0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8,9})
+
+WANT_AUTOMAKE=1.16
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/glib:2
+ dev-libs/libevent
+ dev-libs/jansson
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ sys-libs/zlib
+ net-misc/curl
+ !libressl? ( dev-libs/openssl )
+ libressl? ( dev-libs/libressl )
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+}