summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-03-10 23:38:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-14 21:42:22 +0000
commitfb38cbd4b7f03e04e3275ce0ab540fff373499ea (patch)
tree74ef11bf7e9c382c06a260fb62d1b5be082bcfd7 /net-misc
parentdev-python/virtualenv: keyworded 16.7.9 for sparc, bug #700918 (diff)
downloadgentoo-fb38cbd4b7f03e04e3275ce0ab540fff373499ea.tar.gz
gentoo-fb38cbd4b7f03e04e3275ce0ab540fff373499ea.tar.bz2
gentoo-fb38cbd4b7f03e04e3275ce0ab540fff373499ea.zip
net-misc/getdate: Fix build with glibc-2.31, bump EAPI
* Patches getdate to not use stime (removed in glibc-2.31). (Tested and adjusts time fine.) * Bump EAPI from 4 -> 7 Closes: https://bugs.gentoo.org/709642 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/14923 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/getdate/files/getdate-glibc-2.31.patch13
-rw-r--r--net-misc/getdate/getdate-1.2-r2.ebuild42
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/getdate/files/getdate-glibc-2.31.patch b/net-misc/getdate/files/getdate-glibc-2.31.patch
new file mode 100644
index 000000000000..2926f7c7a2bc
--- /dev/null
+++ b/net-misc/getdate/files/getdate-glibc-2.31.patch
@@ -0,0 +1,13 @@
+--- a/getdate.c
++++ b/getdate.c
+@@ -214,7 +214,9 @@
+ /* Dangerous! Could upset cron and other
+ * timer related events.
+ */
+- stime(&new_time);
++ struct timespec s = {0};
++ s.tv_sec = new_time;
++ clock_settime(CLOCK_REALTIME, &s);
+ print_samples(host, first_sample, second_sample);
+ printf("getdate: set time to %s to match host %s\n",
+ time_to_str(new_time),
diff --git a/net-misc/getdate/getdate-1.2-r2.ebuild b/net-misc/getdate/getdate-1.2-r2.ebuild
new file mode 100644
index 000000000000..93e4e9d1d8e6
--- /dev/null
+++ b/net-misc/getdate/getdate-1.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN}_rfc868"
+MY_P="${MY_PN}-${PV}"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Network Date/Time Query and Set Local Date/Time Utility"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/network/misc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/system/network/misc/${MY_P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-glibc-2.31.patch"
+)
+
+src_prepare() {
+ sed -i -e "/errno.h/ a\#include <string.h>" getdate.c || die
+ # Respect CFLAGS
+ sed -i -e "/CFLAGS/d" Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin getdate
+ doman getdate.8
+ dodoc README getdate-cron
+}