summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-08 12:27:30 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-08 12:28:27 +0200
commitfcca0cb3d914c0d83a35456f0dd5afaa528fd26f (patch)
tree28109473f57b94cdd136cffa12f8eb04949bedf1 /net-misc
parentnet-libs/mbedtls: sparc stable wrt bug #583394 (diff)
downloadgentoo-fcca0cb3d914c0d83a35456f0dd5afaa528fd26f.tar.gz
gentoo-fcca0cb3d914c0d83a35456f0dd5afaa528fd26f.tar.bz2
gentoo-fcca0cb3d914c0d83a35456f0dd5afaa528fd26f.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.07.07.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 39a9b36ab8e6..71069f857684 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.06.27.tar.gz 2224557 SHA256 6ccb3ab1b2e3d5c231b9fff3bffe7c60b3c4973a8269bbe6a5b6835527109bcf SHA512 e117e6c0cab79acc4225bbf6e4bdaa1d439ca35f6018ac49c20c48fd72a0297f703ba5885f6ce378eefa5f26ac94c080682d1012467971ab72803deca3a576f4 WHIRLPOOL b2693ecb168e0ee6d3eab36f4e7ec8e0ae0e18313c3c60fae80fa601c801a245a8559227705a2ad4b12fa6d3ab9175c5fe8806fe19037790f0ba568ac91dd87a
DIST youtube-dl-2016.07.01.tar.gz 2237365 SHA256 ffb6f2b9369ed239e2c139167dc60c521747875a2f5c45917c3b88c8ed74dd36 SHA512 a254954fe6b9b147639bad7ffbcf60d8778b6a9b17f2dedaf3be8f9a17f4271899c1650d7646b440dce8912403dca6cd5c59d988971dc631dd494dad1bc020c3 WHIRLPOOL 1c5cbf1d9a87a14efea052343dbf263b7c6b677cae26ff600073acdd9a68fe4e566773f9f918c4885d377bd5e677362ab27dc27a1f443c6bc9dd4451c5009d4f
+DIST youtube-dl-2016.07.07.tar.gz 2264691 SHA256 9e2008db1f00140233ee188674eef96ba11e6e7bb84a51a9140ceb18f1c6942f SHA512 326fcbc721eed2dd652e2d496693bf173f3024cbf9c68345df0bafca362221233f8503e2b26865353fe76ef036d0a9edaa87cb9a91de61582555d86128b8d979 WHIRLPOOL 4320d44dedfc45cf919a9400a7926af384a6e1b53f0ca890a79ec4fb36471c2d92820f875576ac3a7957617b579adfd646aeed9dcecb16ff9ac05d00f6f17861
diff --git a/net-misc/youtube-dl/youtube-dl-2016.07.07.ebuild b/net-misc/youtube-dl/youtube-dl-2016.07.07.ebuild
new file mode 100644
index 000000000000..969c3bf49e3d
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.07.07.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}