summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-02 22:35:51 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-02 22:38:36 +0200
commitfdc7deed820d17807ef4b6e0ccf6caedb5497d1a (patch)
tree95f69873c679f2a5197309f503066a6aad4aae0b /net-misc
parentapp-crypt/certbot-apache: Sync live (diff)
downloadgentoo-fdc7deed820d17807ef4b6e0ccf6caedb5497d1a.tar.gz
gentoo-fdc7deed820d17807ef4b6e0ccf6caedb5497d1a.tar.bz2
gentoo-fdc7deed820d17807ef4b6e0ccf6caedb5497d1a.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.07.02.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index f3660b8b961a..dd28a46bd3b1 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec7
DIST youtube-dl-2017.06.05.tar.gz 2723532 SHA256 b54ca848490285909d0830c04c19376c2d78da74d8de0056387b11ba34234e8c SHA512 60b99df0e5aa9fc9248cbc47ce8c61f7d78485e6c6b4d8aba795e3a0da9e085d03cf860e94738fe184f8c6bec83897f5fdf5bd24c414bb8153053914203a4b7f WHIRLPOOL cbda1593c1c66524f68a97126465b7fc334b781c144aac6f55652ff454364da2df452bca636bd422ab43391b7c3720d3728d5f1a59b7a7f868d9e5f41b1029d6
DIST youtube-dl-2017.06.18.tar.gz 2728617 SHA256 f53d32c2ca64bb7bf2307666b42c88fa68dcc399f6a92ebed01b8693794e5f99 SHA512 5cf18135beea4331acaf3edc9e8b9c78f9ef2a9c9813a3708936e0c8c5119cf355c1afc932138e650fc4ba831025b2be6bde3fac33a62a49581d5964305bd3d1 WHIRLPOOL 07612cdc1c0463a4640642352833b23834d25e8ba6622a2311a518a227edfc5353e9425a4d889e268b7f6d8c199f0e17dd3197015728db05dd4f83891f40a0b3
DIST youtube-dl-2017.06.25.tar.gz 2737382 SHA256 0531958d4dc10f0fae7960a4c8d08d17fe57acf79719a76387d765c382809f59 SHA512 49a298ab041b264ca4a48b479851bcff96b2a535da8ed280d69fc1799702a43eb38289f00253271d9b320a538a8a374dcc27a0f3148d44db22fa57f8b41afce4 WHIRLPOOL e7bf63b54e35a2061d36c358f000dadb22769e20a1309dd4c43215c0fe1bb4096b198da2245c9ba4c967837d065525229861ca345a6392b83829f2ce58726f82
+DIST youtube-dl-2017.07.02.tar.gz 2740061 SHA256 5b8b11c932ddbc346e2188f0e3a4c0ab8203b1b749f8ea9b212e10d34fa20168 SHA512 08cf4693450ad9ecdad653d4e5508c0899a54e3e16f49f5957ee1ff1486f55333860c3b8ea0d45a1ec12bf5cdc4ce3f57abf9f6c1eb73eca1dd41a38e86bbe68 WHIRLPOOL f28898208dfe3230284f7e6803cb4002a0bd7f493bbc5826ae0ad76ee4453cb5c7413cfc9609fa7bb1131754a07415318e1c380e04a07bba4ff9c88ba1517915
diff --git a/net-misc/youtube-dl/youtube-dl-2017.07.02.ebuild b/net-misc/youtube-dl/youtube-dl-2017.07.02.ebuild
new file mode 100644
index 000000000000..867867e73614
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.07.02.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}