summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-28 07:34:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-28 07:34:34 +0200
commit218fd244af6bbd4aa9d9d42cd28bb1ca56e5be6d (patch)
tree66cf2fee9159b96ae398835382ebc7a52d54cd94 /net-nds/gssproxy
parentnet-im/zoom: Remove old. (diff)
downloadgentoo-218fd244af6bbd4aa9d9d42cd28bb1ca56e5be6d.tar.gz
gentoo-218fd244af6bbd4aa9d9d42cd28bb1ca56e5be6d.tar.bz2
gentoo-218fd244af6bbd4aa9d9d42cd28bb1ca56e5be6d.zip
net-nds/gssproxy: Bump to version 0.8.3
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-nds/gssproxy')
-rw-r--r--net-nds/gssproxy/Manifest1
-rw-r--r--net-nds/gssproxy/gssproxy-0.8.3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-nds/gssproxy/Manifest b/net-nds/gssproxy/Manifest
index d0bdb94b9149..2fcdb719712b 100644
--- a/net-nds/gssproxy/Manifest
+++ b/net-nds/gssproxy/Manifest
@@ -1 +1,2 @@
DIST gssproxy-0.8.2.tar.gz 563300 BLAKE2B 104637af6f43d118ef5194ee8bdfd0a8a8155df43691ac80394de0482f718f2672996b698a80d5c4db7bdc1b164be7f8dc6ffd9a5346affd5923b78362f10333 SHA512 68ce39b36ee83d77da19e9a9fb322ba901366999828a2b427bc2275c4187b4d2291de140c202cce02bdf53eb5cf64da2fafa022ea482258c102f28b0af5d7c63
+DIST gssproxy-0.8.3.tar.gz 565100 BLAKE2B a8b3d96ca0b1cc314af3b63cc5959c9b48287ea0169ea75f8a8902bbd5757542fd24e1fa3f603b2a7d4c15878600145bf5a27e880e935a7a037ca3ebc9fcfb9c SHA512 144b10ec4e19ad2ded5ae57adf1ca311e2fc6c2b97e202eedde69d82c8d50afc0459ac36c7fc5d5290184eb68547a696b33e8a069fde43478104ac26b2c98bc2
diff --git a/net-nds/gssproxy/gssproxy-0.8.3.ebuild b/net-nds/gssproxy/gssproxy-0.8.3.ebuild
new file mode 100644
index 000000000000..703665eae6dd
--- /dev/null
+++ b/net-nds/gssproxy/gssproxy-0.8.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://github.com/gssapi/gssproxy"
+SRC_URI="https://github.com/gssapi/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug selinux systemd hardened"
+
+COMMON_DEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.6.1
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-gssproxy )"
+# We need xml stuff to build the man pages, and people really want/need
+# the man pages for this package :). #585200
+BDEPEND="
+ app-text/docbook-xml-dtd:4.4
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# Many requirements to run tests, including running slapd as root, hence
+# unfeasible.
+RESTRICT="test"
+
+# pkg_setup() {
+# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
+# # allow to specify the openldap use flag, which heimdal doesn't
+# # support.
+# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
+# # schemata required for the tests of gss-proxy.
+# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
+# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
+# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
+# fi
+# }
+
+# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
+# comment: see RESTRICT comment
+# src_prepare() {
+# default
+# # The tests look for kerberos schemata in the documentation
+# # directory of krb5, however these are installed in /etc/openldap
+# # and only if the openldap useflag is supplied
+# sed -i \
+# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
+# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
+# "${S}/tests/testlib.py" || die
+# }
+
+src_configure() {
+ local myeconfargs=(
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ "--localstatedir=${EPREFIX}/var"
+ "--with-os=gentoo"
+ "--with-initscript=$(usex systemd systemd none)"
+ "$(use_with selinux)"
+ "$(use_with debug gssidebug)"
+ "$(use_with hardened hardening)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete || die
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+ insinto /etc/gss/mech.d
+ newins examples/mech gssproxy.conf
+
+ keepdir /var/lib/gssproxy
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -empty -delete || die
+}