summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nds/jxplorer/jxplorer-3.2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nds/jxplorer/jxplorer-3.2-r2.ebuild')
-rw-r--r--net-nds/jxplorer/jxplorer-3.2-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/net-nds/jxplorer/jxplorer-3.2-r2.ebuild b/net-nds/jxplorer/jxplorer-3.2-r2.ebuild
new file mode 100644
index 000000000000..44aa99c9c0b1
--- /dev/null
+++ b/net-nds/jxplorer/jxplorer-3.2-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2 prefix
+
+DESCRIPTION="A fully functional ldap browser written in java"
+HOMEPAGE="http://jxplorer.org/"
+SRC_URI="mirror://sourceforge/${PN}/JXv${PV}src.tar.bz2
+ mirror://sourceforge/${PN}/JXv${PV}deploy.tar.bz2"
+LICENSE="CAOSL"
+IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/javahelp-2.0.02_p46
+ >=dev-java/log4j-1.2.8
+ =dev-java/junit-3.8*"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-com.ca.level.patch"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cp "${FILESDIR}/build.xml" ./build.xml || die
+
+ # Contains stuff for javahelp
+ mkdir dist
+ cp jars/help.jar dist || die
+
+ rm -v jars/*.jar || die
+ mkdir lib/ && cd lib/
+ java-pkg_jar-from javahelp
+ java-pkg_jar-from log4j
+ java-pkg_jar-from junit
+}
+
+EANT_DOC_TARGET="docs"
+EANT_FILTER_COMPILER="jikes"
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar dist/help.jar
+
+ dodir /usr/share/${PN}
+ for i in "icons images htmldocs language templates security connections.txt log4j.xml"
+ do
+ cp -r ${i} "${ED}/usr/share/${PN}" || die
+ done
+
+ dodoc RELEASE.TXT || die
+
+ # By default the config dir is ${HOME}/jxplorer
+ java-pkg_dolauncher ${PN} \
+ --main com.ca.directory.jxplorer.JXplorer \
+ --pwd '"${HOME}/.jxplorer"' \
+ --pkg_args console \
+ -pre "${FILESDIR}/${PN}-pre-r1"
+
+ eprefixify "${ED}/usr/bin/${PN}"
+
+ use source && java-pkg_dosrc src/com
+ use doc && java-pkg_dojavadoc docs
+
+ make_desktop_entry ${PN} JXplorer /usr/share/jxplorer/images/logo_32_trans.gif System
+}