summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-10-06 17:21:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-10-06 17:21:35 -0400
commit69aafed0a8dcbf6c4a108ecd3712f2d36a7bf3c7 (patch)
tree8e75af057172679b23d3e5d01dc69de428a4a1cf /net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild
parentdev-python/dill: keyword for ppc. (diff)
downloadgentoo-69aafed0a8dcbf6c4a108ecd3712f2d36a7bf3c7.tar.gz
gentoo-69aafed0a8dcbf6c4a108ecd3712f2d36a7bf3c7.tar.bz2
gentoo-69aafed0a8dcbf6c4a108ecd3712f2d36a7bf3c7.zip
net-nds/rpcbind: remove _P() macro, bug #589666
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild')
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild b/net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..a8bfe3de1b9c
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.2.3-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug selinux systemd tcpd warmstarts"
+
+CDEPEND=">=net-libs/libtirpc-0.2.3:=
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpcbind )"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ epatch "${FILESDIR}"/${P}-libtirpc.patch
+ epatch "${FILESDIR}"/${P}-mem-corrupt.patch #560990
+ epatch "${FILESDIR}"/${P}-remove-P-macro.patch #589666
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --with-statedir="${EPREFIX}"/run/${PN} \
+ --with-rpcuser=root \
+ --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
+ $(use_enable tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable warmstarts)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}