summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2016-12-30 10:14:09 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-01-04 00:11:26 +0100
commit373389f06e0052723b71d6aa9a2382ce97f490d7 (patch)
tree045f834d02eabbda242cefa03336930741776042 /net-nds/shelldap
parentnet-misc/ethercard-diag: EAPI 6 bump. (diff)
downloadgentoo-373389f06e0052723b71d6aa9a2382ce97f490d7.tar.gz
gentoo-373389f06e0052723b71d6aa9a2382ce97f490d7.tar.bz2
gentoo-373389f06e0052723b71d6aa9a2382ce97f490d7.zip
net-nds/shelldap: version bump to 1.3.2
Updated hompage and source URI. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3282
Diffstat (limited to 'net-nds/shelldap')
-rw-r--r--net-nds/shelldap/Manifest1
-rw-r--r--net-nds/shelldap/metadata.xml4
-rw-r--r--net-nds/shelldap/shelldap-1.3.2.ebuild44
3 files changed, 49 insertions, 0 deletions
diff --git a/net-nds/shelldap/Manifest b/net-nds/shelldap/Manifest
index dc9ac8053557..9d0f18454d9d 100644
--- a/net-nds/shelldap/Manifest
+++ b/net-nds/shelldap/Manifest
@@ -1 +1,2 @@
DIST shelldap-1.3.1.tar.bz2 17794 SHA256 a637a3a941338b5dd6cf184e5a3d640b880ebbea7a9c90edb252f893601aea0d SHA512 be512aebba883e507506901474403e07ab0e4f78075e26c566b6eded6c24b4231d491c5f6e84af57b38408040f6e802d2c6f59c309a2e21e0ab02a0fe08af001 WHIRLPOOL be72dc3db8de5968b3d4f9fa33d037661ae7ce9d628d01f5ea4aaab535657162e79ed8bb481d0d82deb32407910bbe980034a7e9b7de0b01b2d5ca8afebe72a8
+DIST shelldap-1.3.2.tar.gz 18624 SHA256 b4f84cfa164e69c7bdcbbd39416900190df8acf701539fbf0f2576514961c683 SHA512 618cfbbc4e7344571d5ba1a652757aef1526fedd882444ed5df8982414df0dc11cb967443dc0e2b1f1c182bbaa1f7bfebf41906bbc53e9106cdfe7676b558703 WHIRLPOOL 5cf5f07ed8f2a36d19ccb263dcb19c054fe1b64a585166c26856421821336d0edb3f432d3777175ed969486e45536b0ca5231a326400c6319c3162481dcb9ca0
diff --git a/net-nds/shelldap/metadata.xml b/net-nds/shelldap/metadata.xml
index cb3513142de8..db3a6f9ef469 100644
--- a/net-nds/shelldap/metadata.xml
+++ b/net-nds/shelldap/metadata.xml
@@ -20,4 +20,8 @@
content. It keeps command history, has sane autocompletes, credential caching,
site-wide and individual configs, and it's fun to say.
</longdescription>
+ <upstream>
+ <bugs-to>https://bitbucket.org/mahlon/shelldap/issues/</bugs-to>
+ <remote-id type="bitbucket">mahlon/shelldap</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-nds/shelldap/shelldap-1.3.2.ebuild b/net-nds/shelldap/shelldap-1.3.2.ebuild
new file mode 100644
index 000000000000..239920039cd4
--- /dev/null
+++ b/net-nds/shelldap/shelldap-1.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit eutils perl-module
+
+DESCRIPTION="A handy shell-like interface for browsing LDAP servers and editing their content"
+HOMEPAGE="https://bitbucket.org/mahlon/shelldap/"
+SRC_URI="https://bitbucket.org/mahlon/shelldap/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+readline sasl +ssl"
+
+DEPEND=""
+RDEPEND="dev-perl/Algorithm-Diff
+ sasl? ( dev-perl/Authen-SASL )
+ dev-perl/IO-Socket-SSL
+ dev-perl/perl-ldap
+ dev-perl/TermReadKey
+ readline? ( dev-perl/Term-ReadLine-Gnu )
+ dev-perl/Term-Shell
+ dev-perl/YAML-Syck
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_configure() { :; }
+
+src_compile() {
+ pod2man --name "${PN}" < "${PN}" > "${PN}.1" || die 'creating manpage failed'
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "${PN}"
+ dodoc USAGE
+}