summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-04-23 21:06:45 +0000
committerSam James <sam@gentoo.org>2022-05-31 23:12:09 +0100
commit10d9ee0653bff1e38164409ab38d4bded0148527 (patch)
tree7a463f0cfa83ccdf1f4a2924d42fde56608e6ef5 /net-nds
parentapp-misc/chkcrontab: add python3.{10,11} (diff)
downloadgentoo-10d9ee0653bff1e38164409ab38d4bded0148527.tar.gz
gentoo-10d9ee0653bff1e38164409ab38d4bded0148527.tar.bz2
gentoo-10d9ee0653bff1e38164409ab38d4bded0148527.zip
net-nds/phpldapadmin: bump to 1.2.6.3
Bug: https://bugs.gentoo.org/760537 Closes: https://bugs.gentoo.org/755701 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25172 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/phpldapadmin/Manifest1
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.6.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-nds/phpldapadmin/Manifest b/net-nds/phpldapadmin/Manifest
index 3cbc0fcbabda..8b2add41578d 100644
--- a/net-nds/phpldapadmin/Manifest
+++ b/net-nds/phpldapadmin/Manifest
@@ -1 +1,2 @@
DIST phpldapadmin-1.2.5.tar.gz 1117335 BLAKE2B 00d82434dbdadf1f90f5f356ad644d7cfa078cc0696d7cf64e36bc49baf2a5f29bd62fbcd265d9771e713bdd19d4e5708e77e1229199b6712874f982f9b067b0 SHA512 53cf5a8fb3ae3e5fc3c2ab6d23fb9cf731f1d39e122db6531e87461610f13e4bc1c9e8d4fcf7abd2ee5697022a068a9e23d8e039ba79a12929faeb6265920701
+DIST phpldapadmin-1.2.6.3.tar.gz 1130061 BLAKE2B d1183a89db659eeadbf33632edabb1f24d855eea3f37d36128b5a4262a4979f1fa1f963b2d1e43c4d07c988899a7c4cfb72a6f88e13ee5a830654686eaecf183 SHA512 66aeb81c812830968df5d3a2f0ccdd479fe5d7ed3bb729c0fb9991d3efa20263a493b38bfe48c99ad2c93c2ee549f51f53e064fb1381bc7e126ca2ad2bfc3167
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.6.3.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.6.3.ebuild
new file mode 100644
index 000000000000..19c7941c7c92
--- /dev/null
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.6.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PN="phpLDAPadmin"
+DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server"
+HOMEPAGE="http://phpldapadmin.sourceforge.net"
+SRC_URI="https://github.com/leenooks/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/php-7.2[hash(+),ldap,session,xml,nls]
+ virtual/httpd-php
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# http://phpldapadmin.git.sourceforge.net/git/gitweb.cgi?p=phpldapadmin/phpldapadmin;a=commit;h=7dc8d57d6952fe681cb9e8818df7f103220457bd
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.1.1-fix-magic-quotes.patch"
+)
+
+need_httpd_cgi
+
+src_prepare() {
+ mv config/config.php.example config/config.php
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc INSTALL.md
+
+ # Restrict config file access - bug 280836
+ chown root:apache "config/config.php"
+ chmod 640 "config/config.php"
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+ webapp_postinst_txt en "${FILESDIR}"/postinstall2-en.txt
+
+ webapp_src_install
+}