summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2022-03-20 16:07:56 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2022-03-20 16:08:52 -0700
commit4c4745b05a90742b564fef0714e66aec98e415f2 (patch)
tree5d2c229f5cf2521f22f07c0ef503b90b25f5e3d5 /net-nds
parentnet-nds: avoid automagic autoca (diff)
downloadgentoo-4c4745b05a90742b564fef0714e66aec98e415f2.tar.gz
gentoo-4c4745b05a90742b564fef0714e66aec98e415f2.tar.bz2
gentoo-4c4745b05a90742b564fef0714e66aec98e415f2.zip
net-nds/openldap: make src_test run parallel tests
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-2.6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-nds/openldap/openldap-2.6.1.ebuild b/net-nds/openldap/openldap-2.6.1.ebuild
index 62f91410a233..7af43ba480d1 100644
--- a/net-nds/openldap/openldap-2.6.1.ebuild
+++ b/net-nds/openldap/openldap-2.6.1.ebuild
@@ -608,7 +608,15 @@ multilib_src_compile() {
multilib_src_test() {
if multilib_is_native_abi; then
- emake test
+ cd "tests"
+ pwd
+ # emake test => runs only lloadd & mdb, in serial; skips ldif,sql,wt,regression
+ # emake partests => runs ALL of the tests in parallel
+ # wt/WiredTiger is not supported in Gentoo
+ TESTS=( plloadd pmdb )
+ #TESTS+=( pldif ) # not done by default, so also exclude here
+ #use odbc && TESTS+=( psql ) # not done by default, so also exclude here
+ emake "${TESTS[@]}"
fi
}