summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-13 11:54:37 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-13 11:56:28 -0500
commit800eb4146cfe655ca8962d7fb692bae138bdfeb1 (patch)
treef25e59d25dd0a89f5076629cb12285a054b5f674 /net-nds
parentdev-ruby/facter: 3.14.7 bump (diff)
downloadgentoo-800eb4146cfe655ca8962d7fb692bae138bdfeb1.tar.gz
gentoo-800eb4146cfe655ca8962d7fb692bae138bdfeb1.tar.bz2
gentoo-800eb4146cfe655ca8962d7fb692bae138bdfeb1.zip
net-nds/rpcbind: avoid using rpcsvc headers
Closes: https://bugs.gentoo.org/705224 Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/rpcbind-1.2.5-r1.ebuild63
-rw-r--r--net-nds/rpcbind/rpcbind-1.2.5.ebuild7
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild10
3 files changed, 10 insertions, 70 deletions
diff --git a/net-nds/rpcbind/rpcbind-1.2.5-r1.ebuild b/net-nds/rpcbind/rpcbind-1.2.5-r1.ebuild
deleted file mode 100644
index 601f3ec4d427..000000000000
--- a/net-nds/rpcbind/rpcbind-1.2.5-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic systemd
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
- inherit autotools git-r3
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
-fi
-
-DESCRIPTION="portmap replacement which supports RPC over various protocols"
-HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="debug remotecalls selinux systemd tcpd warmstarts"
-REQUIRED_USE="systemd? ( warmstarts )"
-
-CDEPEND=">=net-libs/libtirpc-0.2.3:=
- systemd? ( sys-apps/systemd:= )
- tcpd? ( sys-apps/tcp-wrappers )"
-DEPEND="${CDEPEND}
- net-libs/libnsl
- sys-fs/quota[rpc]
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-rpcbind )"
-
-src_prepare() {
- default
- [[ ${PV} == "9999" ]] && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/sbin
- --sbindir="${EPREFIX}"/sbin
- --with-statedir="${EPREFIX}"/run/${PN}
- --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_systemunitdir)" "no")
- $(use_enable debug)
- $(use_enable remotecalls rmtcalls)
- $(use_enable warmstarts)
- $(use_enable tcpd libwrap)
- )
-
- # Allow configure to find /usr/include/rpc/rpc.h in rpcsvc/mount.h
- # https://bugs.gentoo.org/665222
- append-cppflags "$($(tc-getPKG_CONFIG) --cflags libtirpc)"
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-}
diff --git a/net-nds/rpcbind/rpcbind-1.2.5.ebuild b/net-nds/rpcbind/rpcbind-1.2.5.ebuild
index 5c983718d525..4bd86fa20035 100644
--- a/net-nds/rpcbind/rpcbind-1.2.5.ebuild
+++ b/net-nds/rpcbind/rpcbind-1.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,6 +45,11 @@ src_configure() {
$(use_enable warmstarts)
$(use_enable tcpd libwrap)
)
+
+ # Avoid using rpcsvc headers
+ # https://bugs.gentoo.org/705224
+ export ac_cv_header_rpcsvc_mount_h=no
+
econf "${myeconfargs[@]}"
}
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 57838955f522..eccd9dd4139e 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic systemd
+inherit systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
@@ -25,8 +25,6 @@ CDEPEND=">=net-libs/libtirpc-0.2.3:=
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )"
DEPEND="${CDEPEND}
- net-libs/libnsl
- sys-fs/quota[rpc]
virtual/pkgconfig"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-rpcbind )"
@@ -48,9 +46,9 @@ src_configure() {
$(use_enable tcpd libwrap)
)
- # Allow configure to find /usr/include/rpc/rpc.h in rpcsvc/mount.h
- # https://bugs.gentoo.org/665222
- append-cppflags "$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+ # Avoid using rpcsvc headers
+ # https://bugs.gentoo.org/705224
+ export ac_cv_header_rpcsvc_mount_h=no
econf "${myeconfargs[@]}"
}