summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 22:34:14 +0000
committerSam James <sam@gentoo.org>2022-03-19 22:39:02 +0000
commitb7da48a7fce92735b1cb9353ea9a85afe8acc139 (patch)
tree4adb4287ecc6000142b5eb3d47e642f00e37e01b /net-nds
parentnet-nds/openldap: fix hang in configure (diff)
downloadgentoo-b7da48a7fce92735b1cb9353ea9a85afe8acc139.tar.gz
gentoo-b7da48a7fce92735b1cb9353ea9a85afe8acc139.tar.bz2
gentoo-b7da48a7fce92735b1cb9353ea9a85afe8acc139.zip
net-nds/openldap: add upstream MAKEOPTS patch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/openldap-2.6.1-make-flags.patch59
-rw-r--r--net-nds/openldap/openldap-2.6.1.ebuild1
2 files changed, 60 insertions, 0 deletions
diff --git a/net-nds/openldap/files/openldap-2.6.1-make-flags.patch b/net-nds/openldap/files/openldap-2.6.1-make-flags.patch
new file mode 100644
index 000000000000..bf94f9958d3a
--- /dev/null
+++ b/net-nds/openldap/files/openldap-2.6.1-make-flags.patch
@@ -0,0 +1,59 @@
+https://github.com/openldap/openldap/commit/8e3f87f86a51e78bffefb85968e5684213422cb7
+
+From: Orgad Shaneh <orgad.shaneh@audiocodes.com>
+Date: Tue, 25 Jan 2022 17:38:46 +0200
+Subject: [PATCH] ITS#9788 Fix make jobserver warnings
+
+Running make -j8 issues the following warning for each directory with
+make 4.3:
+make[2]: warning: -j8 forced in submake: resetting jobserver mode.
+
+There is no need to pass MFLAGS. Make picks it up from the
+environment anyway.
+--- a/build/dir.mk
++++ b/build/dir.mk
+@@ -21,7 +21,7 @@ all-common: FORCE
+ @echo "Making all in `$(PWD)`"
+ @for i in $(SUBDIRS) $(ALLDIRS); do \
+ echo " Entering subdirectory $$i"; \
+- ( cd $$i && $(MAKE) $(MFLAGS) all ); \
++ ( cd $$i && $(MAKE) all ); \
+ if test $$? != 0 ; then exit 1; fi ; \
+ echo " "; \
+ done
+@@ -30,7 +30,7 @@ install-common: FORCE
+ @echo "Making install in `$(PWD)`"
+ @for i in $(SUBDIRS) $(INSTALLDIRS); do \
+ echo " Entering subdirectory $$i"; \
+- ( cd $$i && $(MAKE) $(MFLAGS) install ); \
++ ( cd $$i && $(MAKE) install ); \
+ if test $$? != 0 ; then exit 1; fi ; \
+ echo " "; \
+ done
+@@ -39,7 +39,7 @@ clean-common: FORCE
+ @echo "Making clean in `$(PWD)`"
+ @for i in $(SUBDIRS) $(CLEANDIRS); do \
+ echo " Entering subdirectory $$i"; \
+- ( cd $$i && $(MAKE) $(MFLAGS) clean ); \
++ ( cd $$i && $(MAKE) clean ); \
+ if test $$? != 0 ; then exit 1; fi ; \
+ echo " "; \
+ done
+@@ -48,7 +48,7 @@ veryclean-common: FORCE
+ @echo "Making veryclean in `$(PWD)`"
+ @for i in $(SUBDIRS) $(CLEANDIRS); do \
+ echo " Entering subdirectory $$i"; \
+- ( cd $$i && $(MAKE) $(MFLAGS) veryclean ); \
++ ( cd $$i && $(MAKE) veryclean ); \
+ if test $$? != 0 ; then exit 1; fi ; \
+ echo " "; \
+ done
+@@ -57,7 +57,7 @@ depend-common: FORCE
+ @echo "Making depend in `$(PWD)`"
+ @for i in $(SUBDIRS) $(DEPENDDIRS); do \
+ echo " Entering subdirectory $$i"; \
+- ( cd $$i && $(MAKE) $(MFLAGS) depend ); \
++ ( cd $$i && $(MAKE) depend ); \
+ if test $$? != 0 ; then exit 1; fi ; \
+ echo " "; \
+ done
diff --git a/net-nds/openldap/openldap-2.6.1.ebuild b/net-nds/openldap/openldap-2.6.1.ebuild
index 7ca516cae4d6..0e0449e3885e 100644
--- a/net-nds/openldap/openldap-2.6.1.ebuild
+++ b/net-nds/openldap/openldap-2.6.1.ebuild
@@ -144,6 +144,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.6.1-cloak.patch
"${FILESDIR}"/${PN}-2.6.1-flags.patch
"${FILESDIR}"/${PN}-2.6.1-fix-missing-mapping.patch
+ "${FILESDIR}"/${PN}-2.6.1-make-flags.patch
)
openldap_filecount() {