summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-05-09 13:56:45 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-05-09 13:59:41 +0300
commit5d5edfd085c3072f94de858086272045b19a5cfb (patch)
treed2623985a73ad058e625d081a58096921c4a6804 /net-news/canto-daemon/canto-daemon-0.9.7.ebuild
parentnet-mail/mailman: Version bump (diff)
downloadgentoo-5d5edfd085c3072f94de858086272045b19a5cfb.tar.gz
gentoo-5d5edfd085c3072f94de858086272045b19a5cfb.tar.bz2
gentoo-5d5edfd085c3072f94de858086272045b19a5cfb.zip
net-news/canto-daemon: version bump, drop old
Reported-by: Christian Buchinger <cb-gentoo@guya.de> Closes: https://bugs.gentoo.org/668920 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-news/canto-daemon/canto-daemon-0.9.7.ebuild')
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-news/canto-daemon/canto-daemon-0.9.7.ebuild b/net-news/canto-daemon/canto-daemon-0.9.7.ebuild
new file mode 100644
index 000000000000..b7c139a520be
--- /dev/null
+++ b/net-news/canto-daemon/canto-daemon-0.9.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml(+),threads(+)"
+inherit distutils-r1 multilib
+
+DESCRIPTION="Daemon part of Canto-NG RSS reader"
+HOMEPAGE="https://codezen.org/canto-ng/"
+SRC_URI="https://github.com/themoken/canto-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/canto-next-${PV}"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}