summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/yencode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/yencode')
-rw-r--r--net-news/yencode/Manifest1
-rw-r--r--net-news/yencode/metadata.xml8
-rw-r--r--net-news/yencode/yencode-0.46.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/net-news/yencode/Manifest b/net-news/yencode/Manifest
new file mode 100644
index 000000000000..d61ea783ef3b
--- /dev/null
+++ b/net-news/yencode/Manifest
@@ -0,0 +1 @@
+DIST yencode-0.46.tar.gz 241762 SHA256 7c73536b09af087e5494f7c01a6a5e19d6dfc87a9c2a38990d281118bcd210e4 SHA512 5883ec76f2ef3b857f09c79c63f47e2a1cf0354dbc06ff11cafecfda1112c638283ea3a987f906286ccc9dbe9d57f5f35b06ec1c3404dfc46465e722410d34a8 WHIRLPOOL b55dcbd2f5b1d672cd632e168a18cbec1bfe859205d73ad9ba328f9cbbfe00924ff239eec1411f542fee5fe8f171b1e2d6ff6bdbd96363b7997d6b2b031f9250
diff --git a/net-news/yencode/metadata.xml b/net-news/yencode/metadata.xml
new file mode 100644
index 000000000000..ffdc38f1f4d4
--- /dev/null
+++ b/net-news/yencode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-news</herd>
+ <upstream>
+ <remote-id type="sourceforge">yencode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-news/yencode/yencode-0.46.ebuild b/net-news/yencode/yencode-0.46.ebuild
new file mode 100644
index 000000000000..f00ecb814b9c
--- /dev/null
+++ b/net-news/yencode/yencode-0.46.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="yEnc encoder/decoder package"
+HOMEPAGE="http://www.yencode.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc arm ~amd64"
+IUSE="nls"
+
+DEPEND=""
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc AUTHORS NEWS README ChangeLog
+ doman doc/ydecode.1 doc/yencode.1 doc/ypost.1 doc/ypostrc.5
+}