summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-22 15:46:59 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-10-24 05:07:31 +1100
commit436fc595c838251bfa1dfece3cd572c352316f4d (patch)
treeb254af700edbbe182c5a1495a200361c4ab07cd8 /net-news
parentapp-text/xapian-omega: bump to 1.4.1, remove older unstable versions (diff)
downloadgentoo-436fc595c838251bfa1dfece3cd572c352316f4d.tar.gz
gentoo-436fc595c838251bfa1dfece3cd572c352316f4d.tar.bz2
gentoo-436fc595c838251bfa1dfece3cd572c352316f4d.zip
net-news/rssguard: 3.3.5 version bump
Fix HOMEPAGE, SRC_URI Bump EAPI to 6 Unconditionally Qt5-based Gentoo-bug: 571028 Package-Manager: portage-2.3.0
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/files/rssguard-3.3.5-deps.patch25
-rw-r--r--net-news/rssguard/metadata.xml15
-rw-r--r--net-news/rssguard/rssguard-3.3.5.ebuild52
4 files changed, 87 insertions, 6 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index dd3a58c6b710..cfd55838447b 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1 +1,2 @@
DIST rssguard-2.4.0.tar.gz 44439456 SHA256 5b9f87185a1d5b4ebbbd6aa8ff49fe0b470f323e7465c1a7c364198f62ed877e SHA512 ab789af3119fea8a974b0d0c4c15c256b61ea8d143963fcba6c8dfa792191fa7e21a83e8c867bdeec4cf5dec479300016163f529e5337bc22ef533e9b7631f92 WHIRLPOOL 15f3243b077ccab89188b95b0b5450c06b07910555296d483dea283125e09a11f4e0c1327c2e8740fb6cd1aebccc2a874e52558e28a9a5c2fac64de7fd6a0d87
+DIST rssguard-3.3.5.tar.gz 5310573 SHA256 c8f9d05d498e63f5654dca2fc27834403d6cd76f078639a5d6e1b2acbc6e81bf SHA512 3d80cffa20f0f5f625907b0245a09ada18d56a190abddf2bcdc9eaa199867e29b68d445e12eec0dc544469e8ead4df2c6753da634346bf60e0913bdae41951be WHIRLPOOL efc16b622f3a0ddccee05c0ff5ba97933b170a8e1b713bf4cd81baeda745e70c88acd34502a372a34df339ab210b929f331609f022be3d5dc88cb9acc74de697
diff --git a/net-news/rssguard/files/rssguard-3.3.5-deps.patch b/net-news/rssguard/files/rssguard-3.3.5-deps.patch
new file mode 100644
index 000000000000..86733e362afe
--- /dev/null
+++ b/net-news/rssguard/files/rssguard-3.3.5-deps.patch
@@ -0,0 +1,25 @@
+Remove these dependencies that are not used.
+
+--- a/rssguard.pro
++++ b/rssguard.pro
+@@ -164,7 +164,7 @@ message(rssguard: Prefix directory: \"$$PREFIX\".)
+ message(rssguard: Build revision: \"$$APP_REVISION\".)
+ message(rssguard: lrelease executable name: \"$$LRELEASE_EXECUTABLE\".)
+
+-QT += core gui widgets sql network xml printsupport
++QT += core gui widgets sql network xml
+
+ CONFIG *= c++11 debug_and_release warn_on
+ DEFINES *= QT_USE_QSTRINGBUILDER QT_USE_FAST_CONCATENATION QT_USE_FAST_OPERATOR_PLUS UNICODE _UNICODE
+diff --git a/src/miscellaneous/systemfactory.cpp b/src/miscellaneous/systemfactory.cpp
+index da35aba..1d6b2cd 100755
+--- a/src/miscellaneous/systemfactory.cpp
++++ b/src/miscellaneous/systemfactory.cpp
+@@ -35,7 +35,6 @@
+ #include <QFileInfo>
+ #include <QDir>
+ #include <QFutureWatcher>
+-#include <QtConcurrent/QtConcurrentRun>
+ #include <QDesktopServices>
+
+
diff --git a/net-news/rssguard/metadata.xml b/net-news/rssguard/metadata.xml
index e742e1dc2095..12ad4e9c7acc 100644
--- a/net-news/rssguard/metadata.xml
+++ b/net-news/rssguard/metadata.xml
@@ -1,10 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>yngwin@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="bitbucket">skunkos/rssguard</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">martinrotter/rssguard</remote-id>
+ </upstream>
+ <use>
+ <flag name="webengine">Use <pkg>dev-qt/qtwebengine</pkg> for embedded web browser</flag>
+ </use>
</pkgmetadata>
diff --git a/net-news/rssguard/rssguard-3.3.5.ebuild b/net-news/rssguard/rssguard-3.3.5.ebuild
new file mode 100644
index 000000000000..0a93d89dffcc
--- /dev/null
+++ b/net-news/rssguard/rssguard-3.3.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="A tiny RSS and Atom feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +webengine"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.6:5
+ >=dev-qt/qtgui-5.6:5
+ >=dev-qt/qtnetwork-5.6:5
+ >=dev-qt/qtsql-5.6:5
+ >=dev-qt/qtwidgets-5.6:5
+ >=dev-qt/qtxml-5.6:5
+ webengine? ( >=dev-qt/qtwebengine-5.6:5[widgets] )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/linguist-tools-5.6:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-deps.patch" )
+
+src_prepare() {
+ default
+
+ # remove bundled qtbase translations
+ rm localization/qtbase* || die
+ sed -i -e "s|localization/qtbase-[a-z][a-z].ts||g" ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ USE_WEBENGINE=$(usex webengine true false) \
+ LRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease" \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALL_ROOT=.
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}