summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:13:57 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:23 +0000
commit7bcf5cc9fbab7c60e979d97cd17a471e8f708771 (patch)
treec09e1347b4da8d87e027225685aea31e905fc45b /net-news
parentmedia-tv/v4l-utils: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-7bcf5cc9fbab7c60e979d97cd17a471e8f708771.tar.gz
gentoo-7bcf5cc9fbab7c60e979d97cd17a471e8f708771.tar.bz2
gentoo-7bcf5cc9fbab7c60e979d97cd17a471e8f708771.zip
net-news/rsstail: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rsstail/rsstail-2.1.ebuild4
-rw-r--r--net-news/rsstail/rsstail-2.1_p20200310.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/net-news/rsstail/rsstail-2.1.ebuild b/net-news/rsstail/rsstail-2.1.ebuild
index 626c4b85543e..a97a15db70cc 100644
--- a/net-news/rsstail/rsstail-2.1.ebuild
+++ b/net-news/rsstail/rsstail-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,7 @@ src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} -DVERSION=\\\"\$(VERSION)\\\"" \
- LDFLAGS="${LDFLAGS} $(pkg-config --libs mrss)"
+ LDFLAGS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs mrss)"
}
src_install() {
diff --git a/net-news/rsstail/rsstail-2.1_p20200310.ebuild b/net-news/rsstail/rsstail-2.1_p20200310.ebuild
index b795f9e6499d..183b4698fa09 100644
--- a/net-news/rsstail/rsstail-2.1_p20200310.ebuild
+++ b/net-news/rsstail/rsstail-2.1_p20200310.ebuild
@@ -23,7 +23,7 @@ src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} -DVERSION=\\\"\$(VERSION)\\\"" \
- LDFLAGS="${LDFLAGS} $(pkg-config --libs mrss)"
+ LDFLAGS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs mrss)"
}
src_test() {