summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-12 17:15:34 +0100
committerSam James <sam@gentoo.org>2020-12-15 03:07:32 +0000
commitb8e3e2d3f741c890ca9fab557213a7f4277ba562 (patch)
tree1e8f8b7e2acd4881b617981dceb60678ab2809dd /net-news
parentsys-kernel/raspberrypi-image: version bump to 5.4.79_p20201201 (diff)
downloadgentoo-b8e3e2d3f741c890ca9fab557213a7f4277ba562.tar.gz
gentoo-b8e3e2d3f741c890ca9fab557213a7f4277ba562.tar.bz2
gentoo-b8e3e2d3f741c890ca9fab557213a7f4277ba562.zip
net-news/rssguard: version bump to 3.8.3
Closes: https://bugs.gentoo.org/755050 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/18620 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/rssguard-3.8.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index c1a240e5a10b..86c968af3456 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1 +1,2 @@
DIST rssguard-3.5.9.tar.gz 5775322 BLAKE2B f7d91e87b2a55d780bc1eae4f7e55b8059c049d21998f4c2554a84ca1d7b283e3145a556eef77e784d88ae2ad9f016d7b486a12141dceeada69dd1240205de23 SHA512 3a7223767185bf37bef316291b88d60bb2906fdbd0b045aa07c2ca4be19aadaeaa0b8c923f22aaa3483c7db783386744ad1411ad1ab214a8a71ef260948707b9
+DIST rssguard-3.8.3.tar.gz 9865909 BLAKE2B 7afc9dd0cec9ff58164c341f8cb3c6f31608da958a9c64f8099d9ba645cf7bbdaaa76accb3877943eefeb71b9172a13fa43c0ced7d58c6f368cc164e40a5ab39 SHA512 d7c1d18981177880d93bfaf4a87769638804058609f68b8c42db376c4a0e56230b57a29f70054deb30e02634cfa64355ecfe658b5f961a516b990af91c6f3ba8
diff --git a/net-news/rssguard/rssguard-3.8.3.ebuild b/net-news/rssguard/rssguard-3.8.3.ebuild
new file mode 100644
index 000000000000..ee3584a663e8
--- /dev/null
+++ b/net-news/rssguard/rssguard-3.8.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic xdg-utils qmake-utils
+
+DESCRIPTION="Tiny RSS and Atom feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug webengine"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ ebegin 'Sedding pri/install.pri to install to $(get_libdir)'
+ if grep -q 'lib.path = $$quote($$PREFIX/lib/)' pri/install.pri; then
+ sed -i \
+ -e 's:lib.path = $$quote($$PREFIX/lib/):lib.path = $$quote($$PREFIX/'$(get_libdir)'/):' \
+ pri/install.pri || die
+ eend
+ else
+ eend 1
+ eerror 'grep for lib.path = $$quote($$PREFIX/lib/) failed'
+ die 'find out what changed and update the ebuild'
+ fi
+}
+
+src_configure() {
+ # CONFIG+=ltcg is needed because of https://github.com/martinrotter/rssguard/issues/156
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ $(is-flagq -flto* && echo "CONFIG+=ltcg") \
+ USE_WEBENGINE=$(usex webengine true false) \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALL_ROOT=.
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}