summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2023-12-24 11:27:42 +0400
committerSam James <sam@gentoo.org>2024-01-20 12:22:55 +0000
commited7a851c846b47dd26c94b7935386e43effeb8cc (patch)
treea3b96af9f444cf232589373a27cba51584fc64b7 /net-news
parentdev-db/sqlitebrowser: revbump (diff)
downloadgentoo-ed7a851c846b47dd26c94b7935386e43effeb8cc.tar.gz
gentoo-ed7a851c846b47dd26c94b7935386e43effeb8cc.tar.bz2
gentoo-ed7a851c846b47dd26c94b7935386e43effeb8cc.zip
net-news/liferea: add 1.15.5
Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/Manifest1
-rw-r--r--net-news/liferea/liferea-1.15.5.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-news/liferea/Manifest b/net-news/liferea/Manifest
index ef21d4fb6275..c5797377ebf7 100644
--- a/net-news/liferea/Manifest
+++ b/net-news/liferea/Manifest
@@ -1,2 +1,3 @@
DIST liferea-1.14.5.tar.gz 1833641 BLAKE2B 5505e33bd113b3ea0bf7582f75aa968de2b4bbbc659f224062d735bb357177a3eec5dca26dbc22151ccb1659e740ce2068ee2933ef82eb2e3c3a96b31528e570 SHA512 866e795e31644a8546d0fd6eae2976e0c031650caf77aa87e90bc17a55f65d2c207bb295649c7b4d318fb0d628f7cae1fc0d563f59260eddfeafbe9c885f3550
DIST liferea-1.15.4.tar.gz 1861986 BLAKE2B f0052b4d631d93693f526391ed0e137f3a7c198b14c215c963762134d989c0c1c28122a43201761498ac1db88bfb9cde9e19c08e0114bfde02f0a4898371f6be SHA512 dce6ae35f4fefc956ddb674c22a7bcd83b004f8b5fff5797788a1e1738c83adfd9ed075632001f49d7225bc6a6965b42f7903bd08e8f8e46260ea500d1106f8b
+DIST liferea-1.15.5.tar.gz 1878299 BLAKE2B e74c67fa1b124dabdd3abec2ecb7d42e9d3f36bdb14c5edc2f645aa9f163c71822f43e0eb44761c4be8e14e39c7cf74218e825a87a20c208601a8dcbf7629ab8 SHA512 7d3ec5dd46ccecc3879adba1daf180b05e043f256694146dad466fd8f0a7c840a4dff39d5facbbd304cbb287578c7a258cf83191dfd726077ac332b1d167db17
diff --git a/net-news/liferea/liferea-1.15.5.ebuild b/net-news/liferea/liferea-1.15.5.ebuild
new file mode 100644
index 000000000000..b572cce73882
--- /dev/null
+++ b/net-news/liferea/liferea-1.15.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools gnome2-utils optfeature python-single-r1 xdg
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="https://lzone.de/liferea/"
+SRC_URI="https://github.com/lwindolf/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/fribidi
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/json-glib
+ dev-libs/libpeas:0[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ gnome-base/gsettings-desktop-schemas
+ net-libs/libsoup:3.0
+ net-libs/webkit-gtk:4.1=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ # Workaround crash in libwebkit2gtk-4.0.so
+ # https://bugs.gentoo.org/704594
+ WEBKIT_DISABLE_COMPOSITING_MODE=1 \
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Libsecret Support plugin" app-crypt/libsecret[introspection]
+ optfeature "Tray Icon (AppIndicator and GNOME Classic) plugin" \
+ "dev-libs/libayatana-appindicator dev-python/pycairo x11-libs/gdk-pixbuf[introspection]"
+ optfeature "Media Player plugin" media-libs/gstreamer[introspection]
+ optfeature "monitoring network status" net-misc/networkmanager
+ optfeature "Popup Notifications plugin" x11-libs/libnotify[introspection]
+}