summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-22 19:29:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-22 19:29:57 +0200
commit534e779d50a8ca98adcd07887d0096a86dd921e0 (patch)
treef57d90c16da696bec0caf15df88fc2b02ffa97b5 /net-nntp
parentmedia-tv/kodi: Python 3.9 compatibility (diff)
downloadgentoo-534e779d50a8ca98adcd07887d0096a86dd921e0.tar.gz
gentoo-534e779d50a8ca98adcd07887d0096a86dd921e0.tar.bz2
gentoo-534e779d50a8ca98adcd07887d0096a86dd921e0.zip
net-nntp/sabnzbd: bump to v3.0.0 RC2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-3.0.0_rc2.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 74a6e591077d..57137ee640f5 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1,2 +1,3 @@
DIST SABnzbd-2.3.9-src.tar.gz 2738773 BLAKE2B fbb765732c0aab6a47a4d4827d21b1b029c6d40c1c6c335692964210dc4c389e94cd1cdca45bfb3fb8c2fa9adc84f33df0fe3d23a0e4f9143a095eec042a5cf0 SHA512 10a39db9ad7f6d441166da97194b7a281aacd1900f7687bca72c6c2b555114bc2bbdaaba51cb9fcec57aa1b782f20609a07528484ad911ffd9f9eabb54a324fa
DIST SABnzbd-3.0.0RC1-src.tar.gz 2762495 BLAKE2B 5b623e8cc141426459f3d62c3652df41559946a0fd691163428e7b10dfda5518e9701b1a250ed0a7cda6bfda705869ee6a038184ba8f86cfea70d9ea2d09d613 SHA512 00205b1cb4a74455fc48b0ce0579e6849d08b1cedb28ab01f53da8f37bd75268ced201c9e0510ffdf7b51eee6e666e73bec01f537e1ecbdb7f3f6115422b3074
+DIST SABnzbd-3.0.0RC2-src.tar.gz 2673573 BLAKE2B be45d4dae2d51b2f9ae6e9693a0c61482892b2e9c7fdf09b727af3efaeb26d385cef469c9ab1a13b8456794de7d5c8d9e9252b551eeda190943df68eed3ccafc SHA512 d556beb84a6bb9c20a29d17fab1caee092f7d00688301c22d4286cdcc76dd34d36c7d9453367aa3def3a2833f22f7b85c573558f2806877c8c2606d44824eb5c
diff --git a/net-nntp/sabnzbd/sabnzbd-3.0.0_rc2.ebuild b/net-nntp/sabnzbd/sabnzbd-3.0.0_rc2.ebuild
new file mode 100644
index 000000000000..afa365fd3af6
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-3.0.0_rc2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+# Require python-2 with sqlite USE flag
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 systemd
+
+MY_PV="${PV/_rc/RC}"
+MY_PV="${MY_PV//_pre*}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+7za +rar unzip"
+
+# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
+# be in python's sitedir. See: https://sabnzbd.org/wiki/advanced/unix-packaging
+
+COMMON_DEPS="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/cheetah3[${PYTHON_MULTI_USEDEP}]
+ dev-python/cherrypy[${PYTHON_MULTI_USEDEP}]
+ dev-python/configobj[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ dev-python/feedparser[${PYTHON_MULTI_USEDEP}]
+ dev-python/notify2[${PYTHON_MULTI_USEDEP}]
+ dev-python/portend[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/sabyenc-3.3.1[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+DEPEND="${COMMON_DEPS}"
+
+RDEPEND="
+ ${COMMON_DEPS}
+ >=app-arch/par2cmdline-0.4
+ net-misc/wget
+ 7za? ( app-arch/p7zip )
+ rar? ( || ( app-arch/unrar app-arch/rar ) )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ MY_HOMEDIR="/var/lib/${PN}"
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ local d
+
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto "/usr/share/${PN}/${d}"
+ doins -r ${d}/*
+ done
+
+ exeinto "/usr/share/${PN}"
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}/usr/share/${PN}"
+ python_optimize "${ED}/usr/share/${PN}"
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -o "${PN}" -g "${PN}"
+ dodir "/etc/${PN}"
+ keepdir "/var/log/${PN}"
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc {ABOUT,ISSUES}.txt README.mkd licenses/*
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: ${MY_HOMEDIR}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 3; then
+ ewarn
+ ewarn "Due to changes in this release, the queue will be converted when ${PN}"
+ ewarn "is started for the first time. Job order, settings and data will be"
+ ewarn "preserved, but all jobs will be unpaused and URLs that did not finish"
+ ewarn "fetching before the upgrade will be lost!"
+ ewarn
+ break
+ fi
+ done
+ fi
+}