summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2015-10-15 04:23:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-10-23 07:26:32 -0400
commitf0eac2dfbd1498bff1f03350c97d2d12e63e2711 (patch)
treefbf194bb779288a3e367a5d12ff85556cf156d83 /net-p2p/bitcoin-cli
parentx11-terms/pangoterm: Add new snapshot (diff)
downloadgentoo-f0eac2dfbd1498bff1f03350c97d2d12e63e2711.tar.gz
gentoo-f0eac2dfbd1498bff1f03350c97d2d12e63e2711.tar.bz2
gentoo-f0eac2dfbd1498bff1f03350c97d2d12e63e2711.zip
bitcoincore: Bump to 0.11.1
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Diffstat (limited to 'net-p2p/bitcoin-cli')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild
new file mode 100644
index 000000000000..17d993f9a48b
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="cf33f196e79b1e61d6266f8e5190a0c4bfae7224"
+BITCOINCORE_LJR_DATE="20150921"
+BITCOINCORE_IUSE="ljr"
+inherit bash-completion-r1 bitcoincore
+
+DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind \)bitcoind \(bitcoin-cli\)$/\1\2/' contrib/bitcoind.bash-completion
+ bitcoincore_src_prepare
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --enable-util-cli
+}
+
+src_install() {
+ bitcoincore_src_install
+
+ doman contrib/debian/manpages/bitcoin-cli.1
+
+ newbashcomp contrib/bitcoind.bash-completion ${PN}
+}