summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2018-03-23 13:49:16 +0000
committerMichał Górny <mgorny@gentoo.org>2018-04-01 01:08:53 +0200
commitc1066d6df84fc4c3375a52ab174afae1a1c4e0cc (patch)
tree621e0a9a674de7d9f7a1cd02b36145392658b61c /net-p2p/bitcoin-qt
parentnet-libs/libbitcoinconsensus: Bump to 0.16.0 (diff)
downloadgentoo-c1066d6df84fc4c3375a52ab174afae1a1c4e0cc.tar.gz
gentoo-c1066d6df84fc4c3375a52ab174afae1a1c4e0cc.tar.bz2
gentoo-c1066d6df84fc4c3375a52ab174afae1a1c4e0cc.zip
net-p2p/bitcoin-qt: Bump to 0.16.0
Closes: https://bugs.gentoo.org/649562 Closes: https://github.com/gentoo/gentoo/pull/7570
Diffstat (limited to 'net-p2p/bitcoin-qt')
-rw-r--r--net-p2p/bitcoin-qt/Manifest2
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.16.0.ebuild182
-rw-r--r--net-p2p/bitcoin-qt/files/bitcoin-qt-0.16.0-fix_mempoolstats.patch46
-rw-r--r--net-p2p/bitcoin-qt/metadata.xml2
4 files changed, 231 insertions, 1 deletions
diff --git a/net-p2p/bitcoin-qt/Manifest b/net-p2p/bitcoin-qt/Manifest
index 7c7216450f46..c6a97f3d9fb4 100644
--- a/net-p2p/bitcoin-qt/Manifest
+++ b/net-p2p/bitcoin-qt/Manifest
@@ -1,2 +1,4 @@
DIST bitcoin-0.15.1.knots20171111.patches.tar.xz 443024 BLAKE2B 5010c8d0f6a0bc8cd22ca7d7c73d9e4e689e369f0ba39b59f62fa6b6af3dcf938dfc87d33d3fe595a6e54d99734277a34af068dc29a6e984c76d529fbbe2f383 SHA512 455fadeac6ad57be111104680ec6939d6bf235eb49cde89b9716d36f6914c255b1b69cdea459d89b1bbca56099e793be0c8d7aacf592a9d78495068297bb5890
+DIST bitcoin-0.16.0.knots20180322.patches.tar.xz 417544 BLAKE2B f14616c81e0694346fd0714032be501ad0b58e82e2a5fcc623b1fdd316759ae7ac584e6c4ab586e8c9f5a402694a36eceac6b2f1c7441da655479f832a8869bd SHA512 9eca9cbae8ce17b38ddb70326760e33e7812db78e79cfe2d1a3518b34eb8fc87fe4c145e46ab60278b14e70a75b3af238342b4e1808a77cbca4b62b8c72fb1eb
DIST bitcoin-v0.15.1.tar.gz 7550228 BLAKE2B 0cbb7d0e9d0e5e8eb33502a28289c3f9c86b7c531ed179f7e3e8b601a69a423fa736238a2caae890fd8850eb505533995e578e676860a4014922fbc238185ebb SHA512 a09b6cb64a1649d11e3fd6deeb13a07b1bf4bed504a2fc1c585919459ca8ac1af8e5ecc89dee487359e831a8f12625d54f408f95bb341033d6380b82c290c0d9
+DIST bitcoin-v0.16.0.tar.gz 6628305 BLAKE2B 69adb5832e2a708431c06bd8ce695f25cfc2b84e7ccf11e77f40c8ec273146208c70a900d0d32f79790cf67fb359c2731b0cecfc1f27ac2d0c4057228a83aed3 SHA512 7a59de44196a3cd5b75bccfe851e8bd7d5a00ae45b6e771e082326d75846e7c6d1f6d449e18b539b95b25aa12b7b79c462367f1c89438bcd1ca6ec84eb42972c
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0.ebuild
new file mode 100644
index 000000000000..a0987233c6ff
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DB_VER="4.8"
+inherit autotools bash-completion-r1 db-use gnome2-utils xdg-utils
+
+BITCOINCORE_COMMITHASH="4b4d7eb255ca8f9a94b92479e6061d129c91a991"
+KNOTS_PV="${PV}.knots20180322"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="An end-user Qt GUI for the Bitcoin crypto-currency"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~arm ~arm64 ~mips ~ppc ~x86 ~x86-linux"
+
+IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+
+RDEPEND="
+ >=dev-libs/boost-1.52.0:=[threads(+)]
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+ dev-libs/univalue:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ virtual/bitcoin-leveldb
+ bip70? ( dev-libs/protobuf:= )
+ dbus? (
+ dev-qt/qtdbus:5
+ )
+ libevent? ( dev-libs/libevent:= )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ qrcode? (
+ media-gfx/qrencode:=
+ )
+ upnp? ( >=net-libs/miniupnpc-1.9.20150916:= )
+ wallet? ( sys-libs/db:$(db_ver_to_slot "${DB_VER}")=[cxx] )
+ zeromq? ( net-libs/zeromq:= )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ knots? (
+ gnome-base/librsvg
+ media-gfx/imagemagick[png]
+ )
+"
+
+DOCS=( doc/bips.md doc/files.md doc/release-notes.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2017/11/11/release-${PV}/"
+ fi
+ if use bitcoin_policy_rbf; then
+ elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
+ elog "relay transactions paying the highest fee, regardless of receive order."
+ else
+ elog "Replace By Fee policy is disabled: Your node will only accept the first"
+ elog "transaction seen consuming a conflicting input, regardless of fee"
+ elog "offered by later ones."
+ fi
+}
+
+src_prepare() {
+ sed -i 's/^\(complete -F _bitcoind \)bitcoind \(bitcoin-qt\)$/\1\2/' contrib/bitcoind.bash-completion || die
+
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ eapply "${FILESDIR}/${P}-fix_mempoolstats.patch"
+ fi
+
+ eapply_user
+
+ if ! use bitcoin_policy_rbf; then
+ sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
+ fi
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ sed -i 's/^\(Icon=\).*$/\1bitcoin-qt/;s/^\(Categories=.*\)$/\1P2P;Network;Qt;/' contrib/debian/bitcoin-qt.desktop || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ $(use_enable asm)
+ $(use_enable bip70)
+ $(use_with dbus qtdbus)
+ $(use_with libevent)
+ $(use_with qrcode qrencode)
+ $(use_with upnp miniupnpc)
+ $(use_enable upnp upnp-default)
+ $(use_enable test tests)
+ $(use_enable wallet)
+ $(use_enable zeromq zmq)
+ --with-gui=qt5
+ --disable-util-cli
+ --disable-util-tx
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --disable-ccache
+ --disable-static
+ --with-system-leveldb
+ --with-system-libsecp256k1
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ rm -f "${ED%/}/usr/bin/test_bitcoin" || die
+
+ insinto /usr/share/pixmaps
+ if use knots; then
+ newins "src/qt/res/rendered_icons/bitcoin.ico" "${PN}.ico"
+ else
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ fi
+ insinto /usr/share/applications
+ newins "contrib/debian/bitcoin-qt.desktop" "org.bitcoin.bitcoin-qt.desktop"
+
+ use libevent && dodoc doc/REST-interface.md doc/tor.md
+
+ use zeromq && dodoc doc/zmq.md
+
+ newbashcomp contrib/bitcoind.bash-completion ${PN}
+
+ if use kde; then
+ insinto /usr/share/kservices5
+ doins contrib/debian/bitcoin-qt.protocol
+ dosym "../../kservices5/bitcoin-qt.protocol" "/usr/share/kde4/services/bitcoin-qt.protocol"
+ fi
+}
+
+update_caches() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ update_caches
+
+ if use libevent; then
+ elog "To have ${PN} automatically use Tor when it's running, be sure your"
+ elog "'torrc' config file has 'ControlPort' and 'CookieAuthentication' setup"
+ elog "correctly, and add your user to the 'tor' user group."
+ fi
+}
+
+pkg_postrm() {
+ update_caches
+}
diff --git a/net-p2p/bitcoin-qt/files/bitcoin-qt-0.16.0-fix_mempoolstats.patch b/net-p2p/bitcoin-qt/files/bitcoin-qt-0.16.0-fix_mempoolstats.patch
new file mode 100644
index 000000000000..95219c67982b
--- /dev/null
+++ b/net-p2p/bitcoin-qt/files/bitcoin-qt-0.16.0-fix_mempoolstats.patch
@@ -0,0 +1,46 @@
+From 450ac607a3568f8c991df1681155de6fa7f5a5cb Mon Sep 17 00:00:00 2001
+From: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Fri, 23 Mar 2018 20:30:11 +0000
+Subject: [PATCH] Bugfix: GUI/MempoolStats: Avoid dereferencing NULL
+
+---
+ src/qt/mempoolstats.cpp | 12 ++++--------
+ 1 file changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/src/qt/mempoolstats.cpp b/src/qt/mempoolstats.cpp
+index ebc72e95d0..50a3ef71ab 100644
+--- a/src/qt/mempoolstats.cpp
++++ b/src/qt/mempoolstats.cpp
+@@ -79,13 +79,9 @@ void MempoolStats::setClientModel(ClientModel *model)
+
+ void MempoolStats::drawChart()
+ {
+- if (!isVisible())
++ if (!(isVisible() && clientModel))
+ return;
+
+- const bool drawTxCount = cbShowNumTxns->isChecked();
+- const bool drawMinFee = cbShowMinFeerate->isChecked();
+- const bool drawDynMemUsage = cbShowMemUsage->isChecked();
+-
+ if (!titleItem)
+ {
+ // create labels (only once)
+@@ -349,11 +345,11 @@ void MempoolStats::drawChart()
+ QPen linePenRed(QColor(188,49,62, 250), 2, Qt::SolidLine, Qt::RoundCap, Qt::RoundJoin);
+ QPen linePenGreen(QColor(49,188,62, 250), 2, Qt::SolidLine, Qt::RoundCap, Qt::RoundJoin);
+
+- if (drawTxCount)
++ if (cbShowNumTxns->isChecked())
+ redrawItems.append(scene->addPath(txCountPath, linePenRed));
+- if (drawMinFee)
++ if (cbShowMinFeerate->isChecked())
+ redrawItems.append(scene->addPath(minFeePath, linePenGreen));
+- if (drawDynMemUsage)
++ if (cbShowMemUsage->isChecked())
+ {
+ redrawItems.append(scene->addPath(dynMemUsagePath, linePenBlue));
+ redrawItems.append(scene->addPath(dynMemUsagePathFill, QPen(Qt::NoPen), graBru));
+--
+2.16.1
+
diff --git a/net-p2p/bitcoin-qt/metadata.xml b/net-p2p/bitcoin-qt/metadata.xml
index f92f879affd4..c3c11c51b20d 100644
--- a/net-p2p/bitcoin-qt/metadata.xml
+++ b/net-p2p/bitcoin-qt/metadata.xml
@@ -15,7 +15,7 @@
<flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
<flag name="http">Enable support for the JSON-RPC and REST HTTP server (builtin net-p2p/bitcoind)</flag>
<flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
- <flag name="libevent">Use dev-libs/libevent</flag>
+ <flag name="libevent">Use dev-libs/libevent (needed for JSON-RPC, REST, and Tor auto-configuration</flag>
<flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
<flag name="tor">Enable automatic configuration of a Tor hidden service</flag>
<flag name="upnp">Enable Universal Plug and Play</flag>