summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2015-10-16 00:00:03 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-10-23 13:16:17 -0400
commit20bb60b58d093a22f9d875a28f6a80ff3d5aea8b (patch)
tree317ced2591313aea30636d5fda8ab77551f9e911 /net-p2p/bitcoind/bitcoind-9999.ebuild
parentbitcoincore: Bump to 0.11.1 (diff)
downloadgentoo-20bb60b58d093a22f9d875a28f6a80ff3d5aea8b.tar.gz
gentoo-20bb60b58d093a22f9d875a28f6a80ff3d5aea8b.tar.bz2
gentoo-20bb60b58d093a22f9d875a28f6a80ff3d5aea8b.zip
bitcoincore 0.11.1 & 9999: hasufell's suggestions
Diffstat (limited to 'net-p2p/bitcoind/bitcoind-9999.ebuild')
-rw-r--r--net-p2p/bitcoind/bitcoind-9999.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/net-p2p/bitcoind/bitcoind-9999.ebuild b/net-p2p/bitcoind/bitcoind-9999.ebuild
index 5c38561fd52b..71304c3496ab 100644
--- a/net-p2p/bitcoind/bitcoind-9999.ebuild
+++ b/net-p2p/bitcoind/bitcoind-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-BITCOINCORE_IUSE="examples logrotate test upnp +wallet"
+BITCOINCORE_IUSE="examples test upnp +wallet"
BITCOINCORE_NEED_LEVELDB=1
BITCOINCORE_NEED_LIBSECP256K1=1
inherit bash-completion-r1 bitcoincore user systemd
@@ -14,13 +14,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-RDEPEND="
- logrotate? (
- app-admin/logrotate
- )
-"
-DEPEND="${RDEPEND}"
-
pkg_setup() {
local UG='bitcoin'
enewgroup "${UG}"
@@ -28,7 +21,7 @@ pkg_setup() {
}
src_prepare() {
- sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind bitcoind\) bitcoin-cli$/\1/' contrib/${PN}.bash-completion
+ sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind bitcoind\) bitcoin-cli$/\1/' contrib/${PN}.bash-completion || die
bitcoincore_src_prepare
}
@@ -65,8 +58,6 @@ src_install() {
dodoc -r contrib/{bitrpc,qos,spendfrom,tidy_datadir.sh}
fi
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
- fi
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
}