summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-05-03 14:22:29 +0800
committerIan Delaney <idella4@gentoo.org>2016-05-03 14:45:22 +0800
commit2c1b2991bfd7c7fe686836d0f3c1a968b626a8da (patch)
tree449f5ddcc1d7cfaa3b310a2569d6121922e131db /net-p2p/classified-ads/classified-ads-0.10.ebuild
parentRevert "net-p2p/classified-ads: v0.10 version bump. Changes dependency qt4->q... (diff)
downloadgentoo-2c1b2991bfd7c7fe686836d0f3c1a968b626a8da.tar.gz
gentoo-2c1b2991bfd7c7fe686836d0f3c1a968b626a8da.tar.bz2
gentoo-2c1b2991bfd7c7fe686836d0f3c1a968b626a8da.zip
Revert "net-p2p/classified-ads: Classified ads v0.10 version bump. - changed way how test suite is run and fixed 2 unit tests."
This reverts commit a7a6d00357859094ff31fcbaf4eba09de9360022.
Diffstat (limited to 'net-p2p/classified-ads/classified-ads-0.10.ebuild')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.10.ebuild35
1 files changed, 12 insertions, 23 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.10.ebuild b/net-p2p/classified-ads/classified-ads-0.10.ebuild
index a792705205c9..9ff04f5018e3 100644
--- a/net-p2p/classified-ads/classified-ads-0.10.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.10.ebuild
@@ -5,12 +5,11 @@
EAPI=5
PLOCALES="en fi sv da uk"
PLOCALE_BACKUP="en"
-inherit qt4-r2 qmake-utils virtualx vcs-snapshot
+inherit qt4-r2 qmake-utils
-COMMIT_ID="cd0652c52f86f6284b793f26e5362bc8fb8a7118"
DESCRIPTION="Program for displaying classified advertisement items"
HOMEPAGE="http://katiska.org/classified-ads/"
-SRC_URI="https://github.com/operatornormal/classified-ads/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz \
+SRC_URI="https://github.com/operatornormal/classified-ads/archive/${PV}.tar.gz -> classified-ads-${PV}.tar.gz \
https://github.com/operatornormal/classified-ads/blob/graphics/preprocessed.tar.gz?raw=true \
-> classified-ads-graphics-${PV}.tar.gz"
@@ -38,14 +37,13 @@ DEPEND="${RDEPEND}
dev-qt/qttest:4
sys-devel/gdb:0
doc? ( app-doc/doxygen[dot] )
- test? ( dev-libs/libgcrypt:0
- ${VIRTUALX_DEPEND} )
+ test? ( dev-libs/libgcrypt:0 )
"
src_prepare() {
# preprocessed graphics are unpacked into wrong directory
# so lets move them into correct location:
- mv ../classified-ads-graphics-${PV}/* ui/ || die
+ mv ../ui/* ui/ || die
# then just run qmake
qt4-r2_src_prepare
}
@@ -59,19 +57,8 @@ src_compile() {
}
src_test() {
- virtx test_suite
-}
-
-src_install() {
- emake install INSTALL_ROOT="${D}" DESTDIR="${D}"
- use doc && dodoc -r doc/doxygen.generated/html/
-}
-
-# virtualx requires a command that returns number, and does not just die:
-test_suite() {
- cd test || return -1
- echo qmake
- "$(qt4_get_bindir)"/qmake || return -2
+ cd test || die "test suite missing"
+ "$(qt4_get_bindir)"/qmake || die "test suite configure failed"
emake
# test suite will create files under $HOME, set $HOME to point to
# safe location, ideas stolen from
@@ -83,9 +70,11 @@ test_suite() {
result=$?
export HOME=$BACKUP_HOME
if [ $result != "0" ]; then
- echo "test suite failed with error code " `echo $result`
- return $result
- else
- return 0
+ die "test suite failed with error code " `echo $result`
fi
}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}" DESTDIR="${D}"
+ use doc && dodoc -r doc/doxygen.generated/html/
+}