summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-12-01 14:27:19 -0500
committerCraig Andrews <candrews@gentoo.org>2018-12-01 14:40:44 -0500
commitad24ef353b6a1998a659cc747a5c54e5973c47ec (patch)
tree097f4624b269d65f2bd38769559ec345774a2bd6 /net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
parentkde5.eclass: Drop obsolete blockers after kde-apps-18.04.3 removal (diff)
downloadgentoo-ad24ef353b6a1998a659cc747a5c54e5973c47ec.tar.gz
gentoo-ad24ef353b6a1998a659cc747a5c54e5973c47ec.tar.bz2
gentoo-ad24ef353b6a1998a659cc747a5c54e5973c47ec.zip
net-p2p/cpuminer-opt: curl is an unconditional dependency, add test
Closes: https://bugs.gentoo.org/651270 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild')
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index a1f4a660f6b9..38cf197f4977 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ REQUIRED_USE="cpu_flags_x86_sse2"
DEPEND="
dev-libs/gmp:0
dev-libs/jansson
- curl? ( >=net-misc/curl-7.15[ssl] )
+ >=net-misc/curl-7.15[ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
"
@@ -35,7 +35,7 @@ src_prepare() {
src_configure() {
append-ldflags -Wl,-z,noexecstack
- econf --with-crypto $(use_with curl)
+ econf --with-crypto --with-curl
}
src_install() {
@@ -44,3 +44,7 @@ src_install() {
insinto "/etc/${PN}"
doins cpuminer-conf.json
}
+
+src_test() {
+ ./cpuminer --cputest || die
+}