summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-03-19 09:15:26 -0400
committerCraig Andrews <candrews@gentoo.org>2018-03-19 09:16:56 -0400
commitb165532680d67341960a07a6f25f015f008c43a1 (patch)
tree36b01ada640cab6f9315e4ec7415333ef5b18c52 /net-p2p/cpuminer-opt
parentmedia-sound/mumble: Reordered dependencies. (diff)
downloadgentoo-b165532680d67341960a07a6f25f015f008c43a1.tar.gz
gentoo-b165532680d67341960a07a6f25f015f008c43a1.tar.bz2
gentoo-b165532680d67341960a07a6f25f015f008c43a1.zip
net-p2p/cpuminer-opt: 3.8.4 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 2e12fb2621fa..e4d49fba588f 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,2 +1,3 @@
DIST cpuminer-opt-3.8.3.2.tar.gz 1675230 BLAKE2B a0176c1152c695c1fde4f06911407b1aaf88fec8d275c64d2f117606ec82b26deda862a95ff1d866fcd7eece908be9ee1c5bb27d354e80665ab172d3d394dafc SHA512 610ce2bf8702882985d45d2db1cfa0655dcece47116908c2cd59489df1aa2a1f0b03c89af1a2cfa1ab0425e340b8e0b70c4f33b1399c414d90cabfc4f37bed3c
DIST cpuminer-opt-3.8.3.3.tar.gz 1676500 BLAKE2B 7b3415f812c685b6054d4cb7236b681466fa6440c707e461c0fe03e4091906770bbe0851c4cb49d0fe1b99e11a8510f4462c2d8f05373aaa873a12fa7326a247 SHA512 6706930e2a317d54a349a6a5b71cbf4a3a7fb7ff1759376f35884aa21ef947635817c0f17fe82c53685bc652423245fdc25decf9ee23016bf86da47caacc161a
+DIST cpuminer-opt-3.8.4.tar.gz 1679290 BLAKE2B 94df217115f543ce95126553fa0d295e0ed2b13e766c114926ad449370a825cae5b95f5b5c34461f28a100fc102ae5227e2e9686db7500c5d3d4c7e2a3fb1804 SHA512 60bb0bb91a53362c64d7992e1c7e34b09be60d57c4cb150d904985562b5331368ce0d130d6699a292d63af826634f3cad938c84e6684b58d4aa9b31c7489de05
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.4.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.4.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}