summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-02-17 22:35:03 -0500
committerCraig Andrews <candrews@gentoo.org>2018-02-17 23:20:39 -0500
commitbeb7be03f94b48c5d841ca89d33f714344b084f1 (patch)
treefd4fb0ac97130043e9182cbf5bb99af7dab5af54 /net-p2p/cpuminer-opt
parentnet-wireless/gnuradio: lots of work (diff)
downloadgentoo-beb7be03f94b48c5d841ca89d33f714344b084f1.tar.gz
gentoo-beb7be03f94b48c5d841ca89d33f714344b084f1.tar.bz2
gentoo-beb7be03f94b48c5d841ca89d33f714344b084f1.zip
net-p2p/cpuminer-opt: 3.8.2.1 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.2.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 5cc816d5d274..d46d875a5892 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.8.0.1.tar.gz 1656058 BLAKE2B 685e5a7813f32e276a1cdd179c5d518
DIST cpuminer-opt-3.8.0.tar.gz 1656474 BLAKE2B 145126762aeb245d042c1a208b60fd4727b450b77ab2585043b13b82b61b947dea0db2489de08e619dcd54b8eb1ec429f83f21ce1e49c34e140f585eccdd14f0 SHA512 c610d58236c5d84a850e68e172d3fdfede5b86aefa8ff09890ffc43d47efd4754aeb345f6b5fd48b6afcbc771541418f6fde1c9e621ad89c17d2dad4c16151f9
DIST cpuminer-opt-3.8.1.1.tar.gz 1657624 BLAKE2B d408d3da10ea6c0d91d0aa7097e52fb233f9a3c8f921c638899d18f99c1b1522c2d627d6869af6e650929da251f2bf6df87882ffb7169ac5a5633608d9399565 SHA512 f41e175492514c96d088c7f11aec88796b63d91aa8496794fac2222db24090685b4c76439bff39b5c074a5527494dfa8d1be6611b0040f5fca6436a80ea933f4
DIST cpuminer-opt-3.8.1.tar.gz 1654969 BLAKE2B b8805e748b71d3c7049d5c97dd74a51da55f88c697963c938a372ff5ff0ac72fcabce81b86f373fdca2dcef7393bba3f53c049bc30dfbd02691ff5e9630cf5bc SHA512 800edbecf5edb0902adc54480a4984602c19087d55675212832ce24df109b7d66544d9db78112a04c3c374521737e2680013d354b6ff8195a17abeb213e2a556
+DIST cpuminer-opt-3.8.2.1.tar.gz 1668854 BLAKE2B d05238c27bb2fdc806937fde0db8fad81ad07a8f3a19414cf338a5262f112a2b6378657b7c901c41a8461f3ce62662da2758941eecb04f7efad809ffeb9403a3 SHA512 2ff1ac4923c90ebd59a1336cf0114be67571c8eb3d526467546c22a2a291778d77ef842fc814cdf88c589643faaad87dada95cc718680ffba91a19e7f53f1178
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.2.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.2.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}