summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-27 21:04:45 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-27 21:05:02 -0400
commitc58ff38c67ef0dfdd861eb1f5e9f3b81da33adeb (patch)
tree3bb144b80e8dff35722360f167a0d4487307193c /net-p2p/pybitmessage
parentnet-p2p/pybitmessage: new version 0.6.2 thanks to Dmitri Bogomolov. (diff)
downloadgentoo-c58ff38c67ef0dfdd861eb1f5e9f3b81da33adeb.tar.gz
gentoo-c58ff38c67ef0dfdd861eb1f5e9f3b81da33adeb.tar.bz2
gentoo-c58ff38c67ef0dfdd861eb1f5e9f3b81da33adeb.zip
net-p2p/pybitmessage: remove outdated live ebuild.
The ebuild for pybitmessage-9999, which was based on the 0.4.x series, no longer works. I'm removing it for now, but it should be possible to replace it later based on the new 0.6.x series ebuilds (if anyone asks for it). Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-p2p/pybitmessage')
-rw-r--r--net-p2p/pybitmessage/pybitmessage-9999.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-p2p/pybitmessage/pybitmessage-9999.ebuild b/net-p2p/pybitmessage/pybitmessage-9999.ebuild
deleted file mode 100644
index 255677f71ce5..000000000000
--- a/net-p2p/pybitmessage/pybitmessage-9999.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit eutils python-r1 gnome2-utils git-r3
-
-DESCRIPTION="P2P communications protocol"
-HOMEPAGE="https://bitmessage.org"
-EGIT_REPO_URI="https://github.com/Bitmessage/PyBitmessage.git"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="libressl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- !libressl? ( dev-libs/openssl:0[-bindist] )
- libressl? ( dev-libs/libressl )
- dev-python/PyQt4[${PYTHON_USEDEP}]"
-
-src_compile() { :; }
-
-src_install () {
- cat >> "${T}"/${PN}-wrapper <<-EOF || die
- #!/usr/bin/env python
- import os
- import sys
- sys.path.append("@SITEDIR@")
- os.chdir("@SITEDIR@")
- os.execl('@PYTHON@', '@EPYTHON@', '@SITEDIR@/bitmessagemain.py')
- EOF
-
- touch src/__init__.py || die
-
- install_python() {
- python_moduleinto ${PN}
- python_domodule src/*
- sed \
- -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
- -e "s#@EPYTHON@#${EPYTHON}#" \
- -e "s#@PYTHON@#${PYTHON}#" \
- "${T}"/${PN}-wrapper > ${PN} || die
- python_doscript ${PN}
- }
-
- python_foreach_impl install_python
-
- dodoc README.md debian/changelog
- doman man/*
-
- newicon -s 24 desktop/icon24.png ${PN}.png
- newicon -s scalable desktop/can-icon.svg ${PN}.svg
- domenu desktop/${PN}.desktop
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}