summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/saku
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/saku')
-rw-r--r--net-p2p/saku/Manifest1
-rw-r--r--net-p2p/saku/files/saku26
-rw-r--r--net-p2p/saku/files/saku.ini27
-rw-r--r--net-p2p/saku/metadata.xml10
-rw-r--r--net-p2p/saku/saku-3.11.0-r1.ebuild45
5 files changed, 109 insertions, 0 deletions
diff --git a/net-p2p/saku/Manifest b/net-p2p/saku/Manifest
new file mode 100644
index 000000000000..cc98bce0d9b4
--- /dev/null
+++ b/net-p2p/saku/Manifest
@@ -0,0 +1 @@
+DIST saku-3.11.0.tar.gz 239772 SHA256 295fbd77aff51cb8967172f71000f26c37cbe133649b7ad2c050e161a8e61c39 SHA512 e6cb37fa555a43d69523a90d1039dcd9bdbc4e4d14e7a4063849cfcaf3a67f1947bd7e5341f97726030eddf53915304ad948f67ce7fb1cb2b6344e1556cc8467 WHIRLPOOL 9865ac033aa779ac772e63ea32fb629d5850958907a91b0c7a4fcfb6dac3a92fa8ede0084c878d806d9e08c1cdc7f4446de5b1afa7f6ff9750ac9395dbad530f
diff --git a/net-p2p/saku/files/saku b/net-p2p/saku/files/saku
new file mode 100644
index 000000000000..898c885985f4
--- /dev/null
+++ b/net-p2p/saku/files/saku
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PID_DIR=/var/run/saku
+
+depend() {
+ use dns
+ need net
+}
+
+start() {
+ mkdir -p $PID_DIR
+ rm -f ${PID_DIR}/pid.txt
+ ebegin "Starting p2p bbs: saku"
+ start-stop-daemon --start -u saku -g saku --quiet -b \
+ -p ${PID_DIR}/pid.txt --exec /usr/bin/saku
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping p2p bbs: saku"
+ start-stop-daemon --stop --quiet -p ${PID_DIR}/pid.txt
+ eend $?
+}
diff --git a/net-p2p/saku/files/saku.ini b/net-p2p/saku/files/saku.ini
new file mode 100644
index 000000000000..f6c45aa87ba9
--- /dev/null
+++ b/net-p2p/saku/files/saku.ini
@@ -0,0 +1,27 @@
+#
+# Sample saku.ini to run saku in distributed directory.
+# Copyright (c) 2005-2007 shinGETsu Project.
+# $Id$
+#
+
+[Network]
+port: 8000
+upnp: no
+
+[Path]
+prefix: /usr
+var: /var
+sysconfig: /etc
+docroot: %(prefix)s/share/saku/www
+file_dir: %(prefix)s/share/saku/file
+template_dir: %(prefix)s/share/saku/template
+log_dir: %(var)s/log/saku
+run_dir: %(var)s/run/saku
+cache_dir: %(var)s/spool/saku
+spam_list: %(sysconfig)s/saku/spam.txt
+initnode_list: %(sysconfig)s/saku/initnode.txt
+node_allow: %(sysconfig)s/saku/node_allow.txt
+node_deny: %(sysconfig)s/saku/node_deny.txt
+
+[Gateway]
+visitor: ^127
diff --git a/net-p2p/saku/metadata.xml b/net-p2p/saku/metadata.xml
new file mode 100644
index 000000000000..d609455f03fc
--- /dev/null
+++ b/net-p2p/saku/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>naota@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">shingetsu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/saku/saku-3.11.0-r1.ebuild b/net-p2p/saku/saku-3.11.0-r1.ebuild
new file mode 100644
index 000000000000..f04cbd8797d0
--- /dev/null
+++ b/net-p2p/saku/saku-3.11.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils user
+
+DESCRIPTION="a clone of P2P anonymous BBS shinGETsu"
+HOMEPAGE="http://shingetsu.info/"
+SRC_URI="mirror://sourceforge/shingetsu/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/cheetah"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup saku
+ enewuser saku -1 -1 /var/run/saku saku
+}
+
+src_prepare() {
+ sed -i -e "/^prefix/s:/usr:${EPREFIX}/usr:" file/saku.ini || die
+ sed -i -e "s:root/share/doc/saku/:root/share/doc/${PF}/:" setup.py || die
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /etc/saku
+ insinto /etc/saku
+ doins "${FILESDIR}"/saku.ini
+
+ doinitd "${FILESDIR}"/saku
+
+ diropts -o saku -g saku
+ dodir /var/log/saku
+ dodir /var/spool/saku
+}