summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-05-29 10:32:16 +0200
committerDirkjan Ochtman <djc@gentoo.org>2016-05-29 10:32:33 +0200
commitc42fe4a7a668a79575ddf49438ff7719bc653d9f (patch)
treeecf4d3e7e5adddcbfe2b09f74c8c4a6f155babb7 /net-p2p/syncthing
parentgames-roguelike/mangband: initial commit new package bug #139020 (diff)
downloadgentoo-c42fe4a7a668a79575ddf49438ff7719bc653d9f.tar.gz
gentoo-c42fe4a7a668a79575ddf49438ff7719bc653d9f.tar.bz2
gentoo-c42fe4a7a668a79575ddf49438ff7719bc653d9f.zip
net-p2p/syncthing: version bump to 0.13.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-p2p/syncthing')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.13.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 1ac84dd37ad3..b6f9857465ad 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,2 +1,3 @@
DIST syncthing-0.12.25.tar.gz 4469275 SHA256 0374721434d0cb8bdd9464f63ff9705fe0ca14ab1e20d916780cb6347c91e72d SHA512 5bdb03ae5f76faddd54304994e04683f2a950419c8b4902553ea83d623976039bc05195f77fe59e2ef19615e91da308adc93b05061265e485a9dc941f2b750d4 WHIRLPOOL e6a10d1142dca73174bd9514526ad8f8357c930aa02fb2a2940adbd690fd209bcad15c3397daabd77052c5962d320665362a86fcafca3d19513ca6d06adcfd37
DIST syncthing-0.13.2.tar.gz 3928871 SHA256 98dac8cf182222967f96e213dc307ede3ed5c6407bd66faeb81e904de4011e89 SHA512 84a751c6eecd7753a1c52effd3074cb9b75f82050833ce1f1b5070711b21897d0fde3a8bed98b61bcf92ba45aa5fe38c4339a2c9d0908982ca6f25ff6ac8368a WHIRLPOOL b80ed15c954bfec64114958bb57b0f68ff70967877a1be21210e9cb97a9bf72868a47467188ba30478515c1ccebb040a81f6de0ab4b7861db2cc817712b1a5c5
+DIST syncthing-0.13.4.tar.gz 3937983 SHA256 c7ecb7ace4837295a03fc72d0b133d2ec149e412bd998d9247d7d4504ef0f64b SHA512 e7ffaa2f72e81e19ebe190db5384a72e19aae531c0ea7f9603f0683b9adae48ea2c637d0aaa86550b1b6e8f1543576caf9bec69be6264b460a91422cdd9df7df WHIRLPOOL 87c82f8abd5edd3e8e08e5525fcd272db13226577a07478fedb8dd28280468e0862e37119d51eb663e501ce79d97c705ae337d55e35dae562d53dce59e4f8cfd
diff --git a/net-p2p/syncthing/syncthing-0.13.4.ebuild b/net-p2p/syncthing/syncthing-0.13.4.ebuild
new file mode 100644
index 000000000000..79d5258238b5
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.13.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGO_PN="github.com/syncthing/syncthing"
+EGIT_COMMIT=v${PV}
+
+inherit golang-vcs-snapshot systemd user versionator
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN}
+ go run build.go -version "v${PV}" -no-upgrade || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN}
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ cd src/${EGO_PN}
+ doman man/*.[157]
+ dobin bin/*
+ dodoc README.md AUTHORS CONTRIBUTING.md
+ systemd_dounit "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}@.service \
+ "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}-resume.service
+ systemd_douserunit "${S}"/src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+}
+
+pkg_postinst() {
+ if [[ $(get_version_component_range 2) -gt \
+ $(get_version_component_range 2 ${REPLACING_VERSIONS}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(get_version_component_range 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(get_version_component_range 2).0."
+ fi
+}