summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-06-11 09:24:02 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-06-11 14:33:01 -0500
commit2b57da707a4e35d340eb9811c2603d40d0a912c3 (patch)
tree3fa00f348128f5ec65ca47631dbd666f9421483d /net-p2p/tremc
parentapp-emulation/buildah: 1.21.1 bump (diff)
downloadgentoo-2b57da707a4e35d340eb9811c2603d40d0a912c3.tar.gz
gentoo-2b57da707a4e35d340eb9811c2603d40d0a912c3.tar.bz2
gentoo-2b57da707a4e35d340eb9811c2603d40d0a912c3.zip
net-p2p/tremc: add 0.9.2_p20201101
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p/tremc')
-rw-r--r--net-p2p/tremc/Manifest1
-rw-r--r--net-p2p/tremc/tremc-0.9.2_p20201101.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/tremc/Manifest b/net-p2p/tremc/Manifest
index 7e7b6b1bb16f..fefad98dd610 100644
--- a/net-p2p/tremc/Manifest
+++ b/net-p2p/tremc/Manifest
@@ -1 +1,2 @@
DIST tremc-0.9.2.tar.gz 315631 BLAKE2B f5ed154fbfcbdb3e77b678a5827d3f68a6be4033530d6d4e451d57808d43cd5737fff32cf62445d246bfce4d8f02e4cac0c1156603e220e228e61b725d6deaf8 SHA512 d6d6d155ddac918d329226d5c3b53c63fd4fa0b98e30f1eb2cd2226ea598bd7dd81d72f747dc11f4a508bcc0453d90d774c1d8db6dac05ae1ecbc217290b7db3
+DIST tremc-0.9.2_p20201101.tar.gz 334602 BLAKE2B 916274775cb51948b3322f0d037d3130e2032ef31acdbbd2b7c42b17c639a82b9dccfe413db4936e9bd580caa7c1ec140091ad09b06058138e8fc0e4882b6c21 SHA512 acae099b2fd24362c02f24b5a6aca85e5b6b0608080a79e0a9a6950a3f61135e271415d0db60d04e39195272ea6e2e494ee85345db454811d6de430c75b5bece
diff --git a/net-p2p/tremc/tremc-0.9.2_p20201101.ebuild b/net-p2p/tremc/tremc-0.9.2_p20201101.ebuild
new file mode 100644
index 000000000000..df6a3896db78
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.2_p20201101.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="ncurses"
+
+COMMIT="8b6b29163295e5cf12d9d874e80203c5906619c8"
+
+inherit bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}