summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-05-25 14:06:03 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-05-25 14:06:09 -0700
commit192848a1ae5dc146ad9681256754cd8a8feaf259 (patch)
treea0873f2b6885fbfebe2c96ee1ec622cf1efe6ef4 /net-p2p
parentapp-misc/screen: security cleanup (diff)
downloadgentoo-192848a1ae5dc146ad9681256754cd8a8feaf259.tar.gz
gentoo-192848a1ae5dc146ad9681256754cd8a8feaf259.tar.bz2
gentoo-192848a1ae5dc146ad9681256754cd8a8feaf259.zip
net-p2p/bittornado-0.4.1_p20160925-r3: revbump, py3{9,10}, EAPI=7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
new file mode 100644
index 000000000000..36ff74e707da
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN=BitTornado
+MY_P=${MY_PN}-${PV}
+EGIT_COMMIT="ed327c4e1ebbe1fe949be81723527cfda87aeb8d"
+
+DESCRIPTION="John Hoffman's fork of the original bittorrent"
+HOMEPAGE="https://github.com/effigies/BitTornado"
+SRC_URI="https://github.com/effigies/BitTornado/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+# GPL-2 is just for the init script from FILESDIR.
+LICENSE="MIT GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+# Block dev-python/pytest-testmon for bug #693508.
+DEPEND="
+ test? (
+ !!dev-python/pytest-testmon
+ )
+"
+
+S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # https://github.com/effigies/BitTornado/pull/53
+ sed -e 's:"BitTornado.Tracker":\0, "BitTornado.Types":' -i setup.py || die
+ find "${S}" -name '*.py' -print0 | \
+ xargs --null -- \
+ sed -r -i 's:time.clock():time.perf_counter():g ; s:collections.(MutableSet|Set|Sequence|Mapping):collections.abc.\1:g' || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest BitTornado/tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newconfd "${FILESDIR}"/bttrack.conf bttrack
+ newinitd "${FILESDIR}"/bttrack.rc bttrack
+}