summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-11-24 12:09:44 -0500
committerCraig Andrews <candrews@gentoo.org>2019-11-24 12:10:22 -0500
commit2795722210b4977dc215863743dd71616cd2f531 (patch)
tree71e21c1e415e24c26e354a34cf57a1f57f590bcf /net-p2p
parentdev-libs/rocm-opencl-runtime: 2.10.0 version bump (diff)
downloadgentoo-2795722210b4977dc215863743dd71616cd2f531.tar.gz
gentoo-2795722210b4977dc215863743dd71616cd2f531.tar.bz2
gentoo-2795722210b4977dc215863743dd71616cd2f531.zip
net-p2p/cpuminer-opt: 3.9.10 version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.10.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 1876787715f9..f78dd1deaede 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,3 +1,4 @@
+DIST cpuminer-opt-3.9.10.tar.gz 1818868 BLAKE2B aa29c101af2f17b128b264c3c6639d3af9c4bfd1abf0a5139b33d06b68f9c9217d1ad19cdd53fd245fed4b5cb7a0ff81789d9929debea5b8d225c7f8b29ae940 SHA512 46da5f43df0f46a94a160310de74776880fed748ec955220544cc1ff08eada8f9dd774250913ffbaeed8a6237e69bae730c8f18c48e87b8600b9407a6de03cc4
DIST cpuminer-opt-3.9.6.2.tar.gz 1796238 BLAKE2B 5c9ef9e04897ac8e62196bb54606b407ae5df7f48074f91c202a7323f9ebfa5c44361df99ed83f9c67e69080580c9bf1e29607b491c872a2f1385c8c42444940 SHA512 92e96724fc40d974cd80d61c19c7d46b6581ec0e63328bf940cade12231240fa17f26639a6c344cf19c20ea6e6f7dc4178dea7db51a4c7ec85a66ab5e4a5e59d
DIST cpuminer-opt-3.9.7.tar.gz 1797055 BLAKE2B 33f978139a04e5bedd76bf37f20d55e1a910e38bb877adf611b9a3b5a9c83193bde6adf5a93562a57e5b12c5e05b59824709714143b9df9abffb751f20e9543d SHA512 a696847b9c7283e1a05cfae2785311e82a1b84496ca1da2b30bb960d3fcc37991f9ab866b8e32125f66718d89b2b8ac3e680b53da2ec68deff910745603ce6d7
DIST cpuminer-opt-3.9.8.1.tar.gz 1792320 BLAKE2B 2e53e40bebeff44e8197f9a2d8e95e75020739ac8797b7826f7e056d94dc85d4f43994a520abeec5fad8be0c4ef20c2667e1860873810a33026a33dc328fe094 SHA512 42ae191c29c53cc837b8532a1aa00dab19392f48c5e69dced09392d83bb3f949c156db9172fbd765c0ebca6b8fdc48346f4b0b5504ca1c5dd69718ee9c832997
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.10.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.10.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}