summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-23 13:33:41 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-23 13:33:41 +0200
commit2e7be44a1f4a20f5b9495127c89ca78a438e6cbc (patch)
tree559e879049353c4a0b0b5f58addff744918455cf /net-p2p
parentRevert "bitcoincore 0.11.1 & 9999: hasufell's suggestions" (diff)
downloadgentoo-2e7be44a1f4a20f5b9495127c89ca78a438e6cbc.tar.gz
gentoo-2e7be44a1f4a20f5b9495127c89ca78a438e6cbc.tar.bz2
gentoo-2e7be44a1f4a20f5b9495127c89ca78a438e6cbc.zip
Revert "bitcoincore: Bump to 0.11.1"
This reverts commit f0eac2dfbd1498bff1f03350c97d2d12e63e2711.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild33
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.11.1.ebuild104
-rw-r--r--net-p2p/bitcoind/bitcoind-0.11.1.ebuild77
3 files changed, 0 insertions, 214 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild
deleted file mode 100644
index 17d993f9a48b..000000000000
--- a/net-p2p/bitcoin-cli/bitcoin-cli-0.11.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-BITCOINCORE_COMMITHASH="cf33f196e79b1e61d6266f8e5190a0c4bfae7224"
-BITCOINCORE_LJR_DATE="20150921"
-BITCOINCORE_IUSE="ljr"
-inherit bash-completion-r1 bitcoincore
-
-DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-src_prepare() {
- sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind \)bitcoind \(bitcoin-cli\)$/\1\2/' contrib/bitcoind.bash-completion
- bitcoincore_src_prepare
-}
-
-src_configure() {
- bitcoincore_conf \
- --enable-util-cli
-}
-
-src_install() {
- bitcoincore_src_install
-
- doman contrib/debian/manpages/bitcoin-cli.1
-
- newbashcomp contrib/bitcoind.bash-completion ${PN}
-}
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.11.1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.11.1.ebuild
deleted file mode 100644
index d2618cfd98f1..000000000000
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.11.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-BITCOINCORE_COMMITHASH="cf33f196e79b1e61d6266f8e5190a0c4bfae7224"
-BITCOINCORE_LJR_DATE="20150921"
-BITCOINCORE_IUSE="dbus kde ljr +qrcode qt4 qt5 test upnp +wallet zeromq"
-BITCOINCORE_POLICY_PATCHES="cltv cpfp dcmp rbf spamfilter"
-LANGS="ach af_ZA ar be_BY bg bs ca ca@valencia ca_ES cmn cs cy da de el_GR en eo es es_CL es_DO es_MX es_UY et eu_ES fa fa_IR fi fr fr_CA gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_HK zh_CN zh_TW"
-BITCOINCORE_NEED_LEVELDB=1
-BITCOINCORE_NEED_LIBSECP256K1=1
-inherit bitcoincore eutils fdo-mime gnome2-utils kde4-functions qt4-r2
-
-DESCRIPTION="An end-user Qt GUI for the Bitcoin crypto-currency"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-libs/protobuf
- qrcode? (
- media-gfx/qrencode
- )
- qt4? ( dev-qt/qtgui:4 )
- qt5? ( dev-qt/qtgui:5 dev-qt/qtnetwork:5 dev-qt/qtwidgets:5 )
- dbus? (
- qt4? ( dev-qt/qtdbus:4 )
- qt5? ( dev-qt/qtdbus:5 )
- )
-"
-DEPEND="${RDEPEND}
- qt5? ( dev-qt/linguist-tools:5 )
-"
-REQUIRED_USE="${REQUIRED_USE} ^^ ( qt4 qt5 )"
-
-src_prepare() {
- bitcoincore_prepare
-
- local filt= yeslang= nolang=
-
- for lan in $LANGS; do
- if [ ! -e src/qt/locale/bitcoin_$lan.ts ]; then
- die "Language '$lan' no longer supported. Ebuild needs update."
- fi
- done
-
- for ts in $(ls src/qt/locale/*.ts)
- do
- x="${ts/*bitcoin_/}"
- x="${x/.ts/}"
- if ! use "linguas_$x"; then
- nolang="$nolang $x"
- rm "$ts"
- filt="$filt\\|$x"
- else
- yeslang="$yeslang $x"
- fi
- done
- filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
- sed "/${filt}/d" -i 'src/qt/bitcoin_locale.qrc'
- sed "s/locale\/${filt}/bitcoin.qrc/" -i 'src/Makefile.qt.include'
- einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
-
- bitcoincore_autoreconf
-}
-
-src_configure() {
- bitcoincore_conf \
- $(use_with dbus qtdbus) \
- $(use_with qrcode qrencode) \
- --with-gui=$(usex qt5 qt5 qt4)
-}
-
-src_install() {
- bitcoincore_src_install
-
- insinto /usr/share/pixmaps
- newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
- make_desktop_entry "${PN} %u" "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/bitcoin;\nTerminal=false"
-
- dodoc doc/assets-attribution.md doc/bips.md doc/tor.md
- doman contrib/debian/manpages/bitcoin-qt.1
-
- if use kde; then
- insinto /usr/share/kde4/services
- doins contrib/debian/bitcoin-qt.protocol
- fi
-}
-
-update_caches() {
- gnome2_icon_cache_update
- fdo-mime_desktop_database_update
- buildsycoca
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-p2p/bitcoind/bitcoind-0.11.1.ebuild b/net-p2p/bitcoind/bitcoind-0.11.1.ebuild
deleted file mode 100644
index ef75d878db18..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.11.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-BITCOINCORE_COMMITHASH="cf33f196e79b1e61d6266f8e5190a0c4bfae7224"
-BITCOINCORE_LJR_DATE="20150921"
-BITCOINCORE_IUSE="addrindex examples ljr logrotate test upnp +wallet zeromq"
-BITCOINCORE_ADDRINDEX_DIFF="8a915e56f4be5d090d79f01cbd4a23ce1b7e9168...4a6331c5068d8f2c95731518445a57267d506bb5"
-BITCOINCORE_ADDRINDEX_PATCHFILE="bitcoin-addrindex-v0.11.0.patch"
-BITCOINCORE_POLICY_PATCHES="cltv cpfp dcmp rbf spamfilter"
-BITCOINCORE_NEED_LEVELDB=1
-BITCOINCORE_NEED_LIBSECP256K1=1
-inherit bash-completion-r1 bitcoincore user systemd
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- logrotate? (
- app-admin/logrotate
- )
-"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_prepare() {
- sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind bitcoind\) bitcoin-cli$/\1/' contrib/${PN}.bash-completion
- bitcoincore_src_prepare
-}
-
-src_configure() {
- bitcoincore_conf \
- --with-daemon
-}
-
-src_install() {
- bitcoincore_src_install
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "contrib/init/bitcoind.openrcconf" ${PN}
- newinitd "contrib/init/bitcoind.openrc" ${PN}
- systemd_dounit "${FILESDIR}/bitcoind.service"
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/assets-attribution.md doc/bips.md doc/tor.md
- doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
-
- newbashcomp contrib/${PN}.bash-completion ${PN}
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,qos,spendfrom,tidy_datadir.sh}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
- fi
-}