summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-15 11:54:48 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-15 11:56:25 -0400
commit319cf44a5cb923164d6d6dbbcd07d037b053833a (patch)
treee779b28c733e78a0967b9ce03c446c79452ab6a5 /net-p2p
parentnet-analyzer/munin: reset accidental stable keywords (diff)
downloadgentoo-319cf44a5cb923164d6d6dbbcd07d037b053833a.tar.gz
gentoo-319cf44a5cb923164d6d6dbbcd07d037b053833a.tar.bz2
gentoo-319cf44a5cb923164d6d6dbbcd07d037b053833a.zip
net-p2p/cpuminer-opt: 3.9.5.3 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index ddbe88b782ed..1accedf0211c 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -12,4 +12,5 @@ DIST cpuminer-opt-3.9.3.1.tar.gz 1781503 BLAKE2B 3f5df07d6d68343bb074367e3296e08
DIST cpuminer-opt-3.9.4.tar.gz 1787750 BLAKE2B 74c3304f743c7650968f90606f7f12fa26b316634f29c5157cbe774ecbe155cc950d9ab44c227909aacbabba4af98379e22a971956a1b8560ce4c096822d6a88 SHA512 f2dc2dbdafb7c7028521aeec5212df87274b6a5f130c116e58fc575d4cd30dcaf10b4ff59f79e782bc6466db65758770c2f4717e446641e29a3eb9ccf4770011
DIST cpuminer-opt-3.9.5.1.tar.gz 1789716 BLAKE2B 8c2eb876837f86d39c9c665392172654fee8a969c0463e76adf47c1ae631f268ebfacfdddd662c5edb79db3469af2299916a54c3b3ec88a8d3bce62878a0ecb0 SHA512 1da67a4a063781502bc7a2062331388205c6bedec1bbbfd447727b4d3aa23591d794ba8c4b59a9671f232d102298b448b539e54f723d86525ee19ae1e4d7fe52
DIST cpuminer-opt-3.9.5.2.tar.gz 1790289 BLAKE2B 3007e73d7b833f132b1fb50def05f3af5401a4c9d9bd603b8170da07f673eadd9d0033822861636ab3cef7140cf2311e7400864f5030e0b834ef4fa03673a90b SHA512 027e36bdd59e59a7a8e98e7ded40d8f4f5045813db6ff86553b67e5d719dbc4b1281ac185f340ad70e0af463ac03179f42fd979299f42b801018890e55bbe825
+DIST cpuminer-opt-3.9.5.3.tar.gz 1791944 BLAKE2B 7712ac9f1e66acc304a4d2bc6bd026fbf608bc33266b982cf1b302e804f2d7f9954cae75acc643a8755570ecd7ace3216c2ce0be9ed2f56e571c5d77cac71d94 SHA512 2463238275856706bc37b56d235e0ab3c5f17122bc4d01cd8bdcb638a1e87e762e500cf7c1b65f0dd450400ab9b003dfd43b55d23476e46f15f95c2a8d3c18f0
DIST cpuminer-opt-3.9.5.tar.gz 1787557 BLAKE2B e6d5623c2752a4dc6eae669e6daba2f3a0a8542863a3268e632b6d0e4ee2cf203614cebd8e41e33d71c58262bfc90d1df0c7eab0d72db28d8df6f40795bfd887 SHA512 7fc2d7afa9a85a6ec9a9a87eee18f68e61f4875b579bcca3e8d4fc4541a3085ae59b566d2851b978abdf27efeeaa310db430c3efce07bb422548d0bddfda1fa4
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.3.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}