summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-08-26 00:03:11 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-08-26 00:03:11 +0200
commit3458b255219386585ea1e302f4911ab33a9a5b0c (patch)
tree00438d1125711e4f22878a664c13a10a3077504d /net-p2p
parentnet-misc/icaclient: Long overdue bump to version 13.2 (bug #493762) (diff)
downloadgentoo-3458b255219386585ea1e302f4911ab33a9a5b0c.tar.gz
gentoo-3458b255219386585ea1e302f4911ab33a9a5b0c.tar.bz2
gentoo-3458b255219386585ea1e302f4911ab33a9a5b0c.zip
net-p2p/qbittorrent: version bump
Also fix net-libs/rb_libtorrent dependency in live ebuild Gentoo-Bug: 556714 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.2.3.ebuild81
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild2
3 files changed, 83 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index eb7cb672aaac..fce992bce94b 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,4 @@
DIST qbittorrent-3.1.12.tar.xz 2465744 SHA256 d5d5b27958297f0b14cf03af8dd24a0d2a990e108c9a7a6159e4a2fbb1111c83 SHA512 af7cbb1a3158cd1fd6c28f17f1dbb62d94c9d192068b5a683b6b0e19e43664f3d312da055c5c19de75b5849c812b7aa9a0c966a7e464c120e0006bb1ea5a6e5a WHIRLPOOL 632fabec4c33104e55c73433028923033e65f37624aba37649e4f6f5593038fa9868e48787db7b1659690456835fc55dc542510d2f60732c66452d3c748508bf
DIST qbittorrent-3.1.9.2.tar.xz 2231708 SHA256 b07ccdbe1ae079f781c62aff21d47183ae35a8d4e96f43f90503978d1830a361 SHA512 8437fb695fb720132d131e44727c28af46c651576d5321423142c190120c59cc6439f5df2e90486274956d253db657fcbd217a834e3ca53d7681919fee7a2504 WHIRLPOOL e4b00027a57fbce49a9ddcaf6e60fccfabb65393531620afa0416249148e9e17d43398a1016fcf04695d0fa7d0a7b970e5beee0a4ab4e6ff06e6f8c23c90154f
DIST qbittorrent-3.2.0.tar.xz 2595372 SHA256 51781cb121ebeda041fb348e649c4bd97888ee8c1d18328bc547d447b960d1b3 SHA512 0e652a4045d2e034611484009c1ce60c0b365fb6030356ac740555bca3e77f901228a24f21fddc87501f39b737ac15cfff4d3d9a18c913ab03df4d90ceb48634 WHIRLPOOL 5c3d215735a70fcbe01773d3a6676209719d91b25ee5ac68f12767fdfd1108626556802cb58f5e698a80607ad3550b5dea0c97670fdc3d6a4975546da3436b1b
+DIST qbittorrent-3.2.3.tar.xz 2638708 SHA256 86a79f3772bd06736a4be104180187d76c5c8feb2c1cdf1054135b4ba602a914 SHA512 304635f4942776f6be5987ad6a60e2e0e217c913bbe3637cef2dd0bfc65450b894e88c639c96d856d3e937f40d120acc62c194bcb29ae52070ad51e921edbdf7 WHIRLPOOL 33728a4679ef9731645a937c059633d18ff4673ded258185488bc31aab001fe720ab3e3aef23bd8d36f1cf12e98d96ed7383d5cc5b3ecbfa2b065028ddacc4ce
diff --git a/net-p2p/qbittorrent/qbittorrent-3.2.3.ebuild b/net-p2p/qbittorrent/qbittorrent-3.2.3.ebuild
new file mode 100644
index 000000000000..503af6c4e327
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.2.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+MY_P=${P/_}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug +qt4 qt5 webui +X"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
+ >=net-libs/rb_libtorrent-1.0.6
+ sys-libs/zlib
+ qt4? (
+ dev-qt/qtcore:4
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? ( dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_prepare() {
+ epatch_user
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use qt5 && echo --with-qt5)
+ $(use webui || echo --disable-webui)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ use qt4 && eqmake4
+ use qt5 && eqmake5
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 5ae750bcc86b..503af6c4e327 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -30,7 +30,7 @@ REQUIRED_USE="
CDEPEND="
dev-libs/boost:=
>=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
- >=net-libs/rb_libtorrent-1.0.0
+ >=net-libs/rb_libtorrent-1.0.6
sys-libs/zlib
qt4? (
dev-qt/qtcore:4