summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2019-12-30 22:24:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-06 12:39:22 +0200
commit39d71b8868c1f0f540051b295736fc645a6c0ba7 (patch)
tree913731a8da659a1e1ea0abd6d6da78a616d0bca4 /net-p2p
parentdev-lisp/roswell: add bug# for soft blocker (diff)
downloadgentoo-39d71b8868c1f0f540051b295736fc645a6c0ba7.tar.gz
gentoo-39d71b8868c1f0f540051b295736fc645a6c0ba7.tar.bz2
gentoo-39d71b8868c1f0f540051b295736fc645a6c0ba7.zip
net-p2p/mktorrent: Bump to p20180912 and add libressl support
Closes: https://bugs.gentoo.org/704110 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mktorrent/Manifest1
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild2
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild50
3 files changed, 52 insertions, 1 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
index 450d3c6e88a4..dcd03786a519 100644
--- a/net-p2p/mktorrent/Manifest
+++ b/net-p2p/mktorrent/Manifest
@@ -1,2 +1,3 @@
DIST mktorrent-1.0.tar.gz 23089 BLAKE2B debfdbf2691fd1baa9f1647ef1cd64a4e5d8cbcabd77fb7c8a4b7ec5c1abbf4fa56ae54ea51afc58b0807cde8d525c4ac7106d38576e52a71e2776ba0bfcacda SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de
+DIST mktorrent-4c221a05d949a3767a2671de139c6014909daf6b.tar.gz 24574 BLAKE2B e7dcc17aca52c8d1f9d816ce3e89bea5c2b1d7759dba6a00578960b253652506b7e61855d769440056aaa6b0719e6856108ca5b80977152746a648862c71e97b SHA512 49ba2697373a1b40829d50d66faaaeb57fa3893e97283ec2844b447b8e4cf2713d7c0e76e49d3893475f5ce298c3215249751defe0f952d2c52df1bf68f7706c
DIST mktorrent-96090fb175f3cef17ae2499e98c2868363106927.tar.gz 24575 BLAKE2B 85f4c1088a5db91ba9bfa9391c82d81c87436a5ee920441c4e05a0e22d535aa1f3c60a0f2c6918a313f911ce9a586ab0ce725212926ad703f7daeaa4ee8b3e14 SHA512 2016cf9c81c6d35f3e482bb5cf8d0083664cee7131bc57f94ba5d0482df7d9b53e49a622035e1e93b6cebb50da9a29d8d00e2a65d3b84a872d98ed51e75a3a8a
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
index 6e9c5fe03dae..27f73410ced7 100644
--- a/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
new file mode 100644
index 000000000000..40a3a3270d56
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/Rudde/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
+else
+ COMMIT_ID="4c221a05d949a3767a2671de139c6014909daf6b"
+ SRC_URI="https://github.com/Rudde/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="threads +ssl libressl debug"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LONG_OPTIONS=1
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}