summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-11 10:59:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-16 19:59:10 +0200
commit4bc859c48682c5e9502724f639a72955a042a024 (patch)
tree6438b274fdcfb9f2caece240bd19011180c150ed /net-p2p
parentapp-i18n/transifex-client: version bump to 0.12.2, remove old 0.11.1_beta and... (diff)
downloadgentoo-4bc859c48682c5e9502724f639a72955a042a024.tar.gz
gentoo-4bc859c48682c5e9502724f639a72955a042a024.tar.bz2
gentoo-4bc859c48682c5e9502724f639a72955a042a024.zip
net-p2p/airdcpp-webclient: version bump to 1.1.0.
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2068 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.1.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 5dd350c95208..cc2dfafb5ad0 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.0.6.tar.gz 707741 SHA256 10d1303d23341411cab61981c7185fb962a00bec59e2273d08c2c6fe51601411 SHA512 d80f0640a16b2f98f1a193553bbb67763cb327b7db40757bca9368c1fe6a053ef897566db1b7ad4583a438db4e772f2e0cc85c1f795f453109a4ab5d52234350 WHIRLPOOL e1923723377c879958fd4410b03eb1b4ea1e18a468b485c609e4d7fd98479d6a26b958afcd21463913a846c2e3b53634da18aa20d50c08e308865aeedac50362
DIST airdcpp-webclient-1.0.7.tar.gz 717747 SHA256 a98a7a478a99334ddb2ed91eef888cec2ee71601d894d16f100b35e7849f0265 SHA512 15501fa6e7f48241f27b2bbffb977731fe2fb35043ddd6d15575ba5fe29271548093098298a82c67d8f0b32a3194b5a14f1197053c39199612aebc1ab296e0c2 WHIRLPOOL 118ec35af049fdb6ffb24fcf97e1c9e47e6b9e66399dcc83a7137b5a3a8257b3015039f13d690e52d3dac3cacc7c450d6ff5cc13b4d55440a27b7c8b9de3c9cb
+DIST airdcpp-webclient-1.1.0.tar.gz 722280 SHA256 bfd6cba9fedd1ffba92826ec80d0ee97e15a67baba9b55627b489cf54ae28c33 SHA512 ae23108e4ab7175fe84c5effad22974afd27b20f7aaa0b1013c51d87f54b30d86bd13dda12b3af19b8b4bb7996b8ad3895ffdd4ce7992c1505715eaeba2d5a87 WHIRLPOOL 121b3f5f4614bb2c39f475087b16c93451640d3a4d1a6abeae9fcf514d75cfd5c156ea3eefa28cc5bc1d0b1bb0c5c731ae31ec80fe547861b8e8bd96d404aaaf
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.1.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.1.0.ebuild
new file mode 100644
index 000000000000..0fa03c344da9
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}