summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-04-11 09:48:44 -0400
committerCraig Andrews <candrews@gentoo.org>2018-04-11 09:51:45 -0400
commit5741530e52844ae9e2267a2b237289b17401f84f (patch)
treecd6489576770beb8b58d956af21765cbcdf29451 /net-p2p
parentpackage.use.mask: Masked "ldap" USE flag for >=openssh-7.7_p1 (diff)
downloadgentoo-5741530e52844ae9e2267a2b237289b17401f84f.tar.gz
gentoo-5741530e52844ae9e2267a2b237289b17401f84f.tar.bz2
gentoo-5741530e52844ae9e2267a2b237289b17401f84f.zip
net-p2p/cpuminer-opt: 3.8.7.1 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 0bc8c03a681b..4dea72b58d4b 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,4 +2,5 @@ DIST cpuminer-opt-3.8.4.1.tar.gz 1678548 BLAKE2B 86ff1dce5abf735982f1272f6a97a18
DIST cpuminer-opt-3.8.5.tar.gz 1701640 BLAKE2B b42d52da56e141bac42b4e5159325f8344434ecfee6e740fbd3c10cc64b448c6b849b029ea703e0f63e6720625fedcfd84e22dd34fc4a4ce37a88e120337ac1e SHA512 27047b8ee4c2a84f40f62ee6a0a4b24245096ade061d55c3c5374aa12e548aeb6d2dc665799ac81edaabcce63a21af11cef8df6ad050fb8cc7094170ec7a8384
DIST cpuminer-opt-3.8.6.1.tar.gz 1701432 BLAKE2B daef8f5f4d5734e80fba1f21dbf3954ccb521dd102dc50427f934b6dbb66d74db85cc2f778da47723783fb2ccca81c6e318da414bc1aa968f4e9966faf88ccea SHA512 a88a0f9b0eb62b5ab74e97616c9c90220847fef232987409ec1ac6d47e1b85f0de186cbccdb317db001dec2f67cd6ea7d5c738abc6bbb42fbadbca53492441db
DIST cpuminer-opt-3.8.6.tar.gz 1701535 BLAKE2B ed51168879e6ca6ada67f13b7325b36c8e58dd3d6d71c55993e84ff9363864fd503f70849fd29366607e57b23f1493539e0e17d1043295266ed4505fbd032cb7 SHA512 57ab3ff3f0a298a4c24d0d8cf4f145627435bbdc4577952995a8babbd7838ae36e56a0d1e2b4c8900af6beecae95af29fef58b74b9afb5268307b67043ef93c4
+DIST cpuminer-opt-3.8.7.1.tar.gz 1707776 BLAKE2B 134c25fab106db6fad601010f8f91a82e42bc03b94e633ffd3db3ef3d4eb05f2561e1249c06f3505a03abbb95976ebfcbcbad225166bc2208a123df15859036a SHA512 74cd569718cf8402cb25a4be4e9d94a897a697e02c7c9f6422313c3a3026f3d12a8eea9669b3a253fdfb471311bf49f8209f35efacb84fd3151e4ac8acda2ed7
DIST cpuminer-opt-3.8.7.tar.gz 1707993 BLAKE2B c1a3156c02a3adf80b75fd6766c3bb7d20755813f90b2669ff6d462990ef2b80a97218b0a30fb559c8c2b3902bdc194e01f463351778f6fbd2a8a08c44da3e81 SHA512 c2aee02586712591d609748e5dbf90d5e28050fa4611915e216a6fef79fdb7ea2e0c31b844457fd505f2cc6892268dbcaebe3ed6b00f2efe9734c8d19ba8096a
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}