summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-11 10:53:27 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-11 10:55:42 -0400
commit57f3f77d63c55b82bc6cf1b682a3805e6ed4ec79 (patch)
tree22d2679b27195cdd9a84580347fde590eaee3efb /net-p2p
parentnet-libs/nodejs: Call xdg_environment_reset() from xdg-utils.eclass (diff)
downloadgentoo-57f3f77d63c55b82bc6cf1b682a3805e6ed4ec79.tar.gz
gentoo-57f3f77d63c55b82bc6cf1b682a3805e6ed4ec79.tar.bz2
gentoo-57f3f77d63c55b82bc6cf1b682a3805e6ed4ec79.zip
net-p2p/cpuminer-opt: 3.9.9 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index a0f74d703c01..8adbf26d852b 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.9.6.2.tar.gz 1796238 BLAKE2B 5c9ef9e04897ac8e62196bb54606b40
DIST cpuminer-opt-3.9.7.tar.gz 1797055 BLAKE2B 33f978139a04e5bedd76bf37f20d55e1a910e38bb877adf611b9a3b5a9c83193bde6adf5a93562a57e5b12c5e05b59824709714143b9df9abffb751f20e9543d SHA512 a696847b9c7283e1a05cfae2785311e82a1b84496ca1da2b30bb960d3fcc37991f9ab866b8e32125f66718d89b2b8ac3e680b53da2ec68deff910745603ce6d7
DIST cpuminer-opt-3.9.8.1.tar.gz 1792320 BLAKE2B 2e53e40bebeff44e8197f9a2d8e95e75020739ac8797b7826f7e056d94dc85d4f43994a520abeec5fad8be0c4ef20c2667e1860873810a33026a33dc328fe094 SHA512 42ae191c29c53cc837b8532a1aa00dab19392f48c5e69dced09392d83bb3f949c156db9172fbd765c0ebca6b8fdc48346f4b0b5504ca1c5dd69718ee9c832997
DIST cpuminer-opt-3.9.8.tar.gz 1792693 BLAKE2B e08866a17e29491430ef2896b79336a78b8fd74696812c406be9454c59ec07c5d65237714375888a06d15cceaaf8465658004f73d0371f0e95f7954fae2c22fe SHA512 af50d7cbc4890697cc006887053d7fe7ec516dc13709bdb61c77ba1322fa7c6ce0c942ea9fc1881ce9ae43524b20f7182d574e546ef4e0fc479a0827658329af
+DIST cpuminer-opt-3.9.9.tar.gz 1819335 BLAKE2B 1fccbcb1615eb9a11b242c462e4b6a1c2bdd9340311a53f8b5a1827aeb008da07b695e0c8d2af42621fed895268fd6324a2a73bbc6ec311b4900fc911a658e06 SHA512 d53b721f3e961f8a61b28bb164c2a470ed2c230c00263dcc67182e8b20b54d7905c65b96e01ad3e639888d3f3aa2e978cfa712ea4a3f34826d314fcd08485417
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.9.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.9.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}