summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-11-01 09:39:44 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-11-01 09:39:44 +0300
commit5bda9e060fdfa9909e5701c8357d12452b4ea4ad (patch)
tree8ac6b215d3a0f1f7fa985fbf86887baf0ca14bbc /net-p2p
parentapp-misc/cfiles: Bump version to 1.8 (diff)
downloadgentoo-5bda9e060fdfa9909e5701c8357d12452b4ea4ad.tar.gz
gentoo-5bda9e060fdfa9909e5701c8357d12452b4ea4ad.tar.bz2
gentoo-5bda9e060fdfa9909e5701c8357d12452b4ea4ad.zip
net-p2p/qbittorrent: Version bump (v4.1.9.1)
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.9.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 5790de685fc5..ae7ee2ed06ce 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.1.7.tar.gz 7803389 BLAKE2B 6a8cf01c2bd86b63b629877fd3446db4aedd1591058af24c14dd4b69f0abae7f3ca715190fa0496b1a3ec742d4ee12585dd27e27c1465a1d22a149c2d47608ca SHA512 59fc6dc9696fbcfb9325017dcb5514f866e7f9e9eda9b4487c29c94d445709f1f3fab35f9817b62da75757360239362d77024d708eae48e89dffdde4ed272be4
DIST qbittorrent-4.1.8.tar.gz 7803739 BLAKE2B ee56e004945025f06b179b08e938c6a3182f252c3bed6990158634ea1fdfd525fd67d105fd7ecdf0217a4bd73d847c5007d1e95f492f4f4e41c32d22dd6b7523 SHA512 8920e98f8db5dd738caab8815cc4a10950c34ba2eaa19b50479bb2ab548f6f297534759d71791caa4c8bfbea92d4b71d223a27fae150e00cc0a262eb3370a1e3
+DIST qbittorrent-4.1.9.1.tar.gz 7804066 BLAKE2B b5fddfdef8773318991ee5a3a818101b46fd0f258c24eebe2a9dde3f9e806544159c373406f609a911b330e32257b3d58a7d81e830ed91cce205182cde16052a SHA512 2a132202762461293ee8e4248bf7d512b3c33ec73670bf4c5c22261be546a69a69775b6c4baacd97a3f9055145cdb4153de17704b6b574b33370f3b454b1def9
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.9.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.9.1.ebuild
new file mode 100644
index 000000000000..e4e1c16a3150
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.1.9.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ =net-libs/libtorrent-rasterbar-1.1*:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}