summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-05-30 17:17:38 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-05-30 17:20:13 -0500
commit631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6 (patch)
treed90021adeade17015dca1c89511c4b389cbb8071 /net-p2p
parentnet-p2p/arti: drop 0.1.0, 0.2.0 (diff)
downloadgentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.tar.gz
gentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.tar.bz2
gentoo-631a1e5cd0e3adb5cc71d7cbfb30580529aea4e6.zip
net-p2p/tremc: add 0.9.3
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/tremc/Manifest1
-rw-r--r--net-p2p/tremc/tremc-0.9.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/tremc/Manifest b/net-p2p/tremc/Manifest
index bf328bea1731..99bae34ad814 100644
--- a/net-p2p/tremc/Manifest
+++ b/net-p2p/tremc/Manifest
@@ -1 +1,2 @@
DIST tremc-0.9.2_p20201101.tar.gz 334602 BLAKE2B 916274775cb51948b3322f0d037d3130e2032ef31acdbbd2b7c42b17c639a82b9dccfe413db4936e9bd580caa7c1ec140091ad09b06058138e8fc0e4882b6c21 SHA512 acae099b2fd24362c02f24b5a6aca85e5b6b0608080a79e0a9a6950a3f61135e271415d0db60d04e39195272ea6e2e494ee85345db454811d6de430c75b5bece
+DIST tremc-0.9.3.tar.gz 334602 BLAKE2B 916274775cb51948b3322f0d037d3130e2032ef31acdbbd2b7c42b17c639a82b9dccfe413db4936e9bd580caa7c1ec140091ad09b06058138e8fc0e4882b6c21 SHA512 acae099b2fd24362c02f24b5a6aca85e5b6b0608080a79e0a9a6950a3f61135e271415d0db60d04e39195272ea6e2e494ee85345db454811d6de430c75b5bece
diff --git a/net-p2p/tremc/tremc-0.9.3.ebuild b/net-p2p/tremc/tremc-0.9.3.ebuild
new file mode 100644
index 000000000000..f08595a9ba3e
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="8b6b29163295e5cf12d9d874e80203c5906619c8"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+# Github tag tarballs include the repo with commit in the dir's name
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}