summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-22 22:46:51 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-22 22:47:03 +1100
commit6d91415f440872933a88db8162b0728771f4f4b4 (patch)
tree1365e0e2b18b3d3862a3609e627f3e10abec4084 /net-p2p
parentsci-libs/opencascade: Quote has_version argument. (diff)
downloadgentoo-6d91415f440872933a88db8162b0728771f4f4b4.tar.gz
gentoo-6d91415f440872933a88db8162b0728771f4f4b4.tar.bz2
gentoo-6d91415f440872933a88db8162b0728771f4f4b4.zip
net-p2p/qbittorrent: avoid Werror
Closes: https://bugs.gentoo.org/641382 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
index 24631e72b86e..7316bdc01781 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ default
+
+ # bug 641382
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 24631e72b86e..26971a131175 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ default
+
+ # bug 641382
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON