summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-10-23 16:09:54 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-23 16:22:30 +0200
commit80e957f38969ec82410479b12a7ddb3e7240e521 (patch)
treeeb9b4b18ed50dd40ec302b4d75477db6b2cf2eca /net-p2p
parentsci-libs/scikits_timeseries: update metadata.xml file. (diff)
downloadgentoo-80e957f38969ec82410479b12a7ddb3e7240e521.tar.gz
gentoo-80e957f38969ec82410479b12a7ddb3e7240e521.tar.bz2
gentoo-80e957f38969ec82410479b12a7ddb3e7240e521.zip
net-p2p/airdcpp-webclient: version bump to 1.3.1.
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2647 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.3.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index a713d5ecadaa..93701c6ddd8c 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.2.0.tar.gz 724103 SHA256 d85177c3183b93c9573dd325c67724b5e86ec50f50c4a6b00797f3b6d22caf98 SHA512 d84e9970f4e3c354bfd97b6b0a6a62657a05817f0444afc56717b0e77e1f15b4c3598f024a0f6c096e55e5b36230ffd25cbc7953131c293b386722871535fccb WHIRLPOOL 9fe690371cdc6ca56e2d8c8513dd83d8fd67a9c4a68ae625a8c14781cb17aa7bed31c7e0375c3180705ea7855aaa7f511bcfcf172d66ce2128364e6abf5fe9d7
DIST airdcpp-webclient-1.3.0.tar.gz 731114 SHA256 1515d2f4672dc40f217e29ac724d9b4d7dd8e5a469d27934d9f02b5f5fb770eb SHA512 98f5cc8a58431a8cfd73338eac843342ca3b1d6d6d59837c6fb1b6af54ab4c35b128029358b1545e492b2887f58ceb1aed548ef4ed1e835eb2290469c72b4a54 WHIRLPOOL 6c5284657968cb00966fb73b57e816411fd667c2d1dd75c02e36ab90a59d03ed3858fc960b8f33a1b10951f00f0e73ce94fb0f0077623f2ff83ca47a72b587d3
+DIST airdcpp-webclient-1.3.1.tar.gz 736889 SHA256 3ec4e2aca343a7d715008482b8197c09b00677d8cb2798470274d944e6e4f5bf SHA512 0a2b4e7a6d639167d51d7ddd4a40e577df7a8babd76df7af7a3a7eb246f73b9840a1f0d96e2a3b494cd05a881881167cc7932b676e9e7d64a28a100c4e0b7467 WHIRLPOOL ea11b7ed94cf4c1fd5ffed0b7e64781bee2b1f4a8255204d662b63bef46bf9808c006ca2b9d6bde572abbfc3e98e25e6300e5ddb99ce90d3717bf2a811433d19
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.3.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.3.1.ebuild
new file mode 100644
index 000000000000..0fa03c344da9
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}