summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-10-22 21:49:13 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2019-10-22 21:49:30 +0200
commit8a0edcbcdab5586ea0568d7a16b2bc299a97e2df (patch)
tree8acaecfa67a5cb760c5be72e853378361dd6a00d /net-p2p
parentnet-p2p/vuze-5.7.6.0: bump (diff)
downloadgentoo-8a0edcbcdab5586ea0568d7a16b2bc299a97e2df.tar.gz
gentoo-8a0edcbcdab5586ea0568d7a16b2bc299a97e2df.tar.bz2
gentoo-8a0edcbcdab5586ea0568d7a16b2bc299a97e2df.zip
net-p2p/vuze-coreplugins-5.7.6.0: bump
Closes: https://bugs.gentoo.org/620404 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/vuze-coreplugins/Manifest1
-rw-r--r--net-p2p/vuze-coreplugins/vuze-coreplugins-5.7.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-p2p/vuze-coreplugins/Manifest b/net-p2p/vuze-coreplugins/Manifest
index eaf4815f69b1..8f10aca5ecf6 100644
--- a/net-p2p/vuze-coreplugins/Manifest
+++ b/net-p2p/vuze-coreplugins/Manifest
@@ -6,3 +6,4 @@ DIST azupdater_1.8.17.zip 26023 BLAKE2B 2db0d88bc5aef807d4116bb8a0aacb89aa1ba594
DIST azupdater_1.9.2.zip 26390 BLAKE2B 9c146beee646cd4a31a1014286d4a2bdbe791b5841c0bc2dca1d0740546f224d34294efcc0ae7a36ae21b8a9e93a442369af8e896255bb11518a5a80b27fff11 SHA512 8a1b37d69e6c955f0e507c5455ae198c162f9de2f1713abd6d47bc9f32e65b6afba15152956f98eca101fbf4dbbecaa5b0f84813dcf11e9b7bf33171ce7432cd
DIST azupnpav_0.4.6.zip 247837 BLAKE2B 1c4060515b963bc1edab9a8f5195232aec268eabc67830c94ace69868726e89ff697647c1f00056cb551c53b517c672990dcb7693f025f8f4a6c6cf77dde0b4c SHA512 eee392cf82aae37b2689ce086fb00727728064552ca31bbf228d3d76407c15f92d30527b979dfc555dbf3a1ead65d991c55d8c517c0f5c93d5a3890b88bfa6b1
DIST azupnpav_0.5.6.zip 264588 BLAKE2B dafaaa89dc9978e06e40bb56e4a76523c2c5e66f0e01beaa0af1b216f2f23348850c93d2f4e85ee2c9458b3d932dc44598a1d72f9c0149964e0533b30395dc59 SHA512 f780e708db51eb4e02ee1dedd445aa72f8a52dc6711d473b93339a2db9492654f93d44cde8456bb7db457b3bca88e15132ce0bc5221247ccb34672ae58bca172
+DIST azupnpav_0.5.7.zip 264998 BLAKE2B 70a8864c61a9b9c3520ae04b0576678c768c619de1f822cfa7968617d7d37597077126b7b562d7a6ebd7458fa8a4e1fecd733be2db41ebe2aec7b8825d00f669 SHA512 f58fa8a3e26d204080a8567240bcbac2868233137ddb073c2ca0c91c17ace5f7a07cebfb1eef04e7fb18eb9287418329b5ca742681806fce78a975e0053ddf1c
diff --git a/net-p2p/vuze-coreplugins/vuze-coreplugins-5.7.6.0.ebuild b/net-p2p/vuze-coreplugins/vuze-coreplugins-5.7.6.0.ebuild
new file mode 100644
index 000000000000..81ad877b00ab
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/vuze-coreplugins-5.7.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# update these when bumping the version
+PLUGINS_V=2.1.10 # http://www.vuze.com/plugins/details/azplugins
+RATING_V=1.5.19 # http://www.vuze.com/plugins/details/azrating
+UPDATER_V=1.9.2 # http://www.vuze.com/plugins/details/azupdater
+UPNPAV_V=0.5.7 # http://www.vuze.com/plugins/details/azupnpav
+
+PLUGINS_DIST=azplugins_${PLUGINS_V}.jar
+RATING_DIST=azrating_${RATING_V}.jar
+UPDATER_DIST=azupdater_${UPDATER_V}.zip
+UPNPAV_DIST=azupnpav_${UPNPAV_V}.zip
+
+ALLPLUGINS_URL="http://azureus.sourceforge.net/plugins"
+
+DESCRIPTION="Core plugins for Vuze that are included in upstream distribution"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="
+ ${ALLPLUGINS_URL}/${PLUGINS_DIST}
+ ${ALLPLUGINS_URL}/${RATING_DIST}
+ ${ALLPLUGINS_URL}/${UPDATER_DIST}
+ ${ALLPLUGINS_URL}/${UPNPAV_DIST}"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="~net-p2p/vuze-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir -p plugins/{azplugins,azrating,azupdater,azupnpav} || die
+ cp "${DISTDIR}"/${PLUGINS_DIST} plugins/azplugins || die
+ cp "${DISTDIR}"/${RATING_DIST} plugins/azrating || die
+ cd "${WORKDIR}"/plugins/azupdater && unpack ${UPDATER_DIST} || die
+ cd "${WORKDIR}"/plugins/azupnpav && unpack ${UPNPAV_DIST} || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/vuze/
+ doins -r "${WORKDIR}/plugins"
+}