summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-04-29 19:59:16 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-30 14:59:55 +0300
commit8fdc38a726c736a53e956162bcc91f3aa49aa7b6 (patch)
tree3aff5f337d29166bea966f10bbdf073192d61de6 /net-p2p
parentapp-i18n/transifex-client: add support for Python 3.8 (diff)
downloadgentoo-8fdc38a726c736a53e956162bcc91f3aa49aa7b6.tar.gz
gentoo-8fdc38a726c736a53e956162bcc91f3aa49aa7b6.tar.bz2
gentoo-8fdc38a726c736a53e956162bcc91f3aa49aa7b6.zip
net-p2p/amule: Add missing readline dep to live ebuild
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-p2p/amule/amule-9999.ebuild b/net-p2p/amule/amule-9999.ebuild
index f14cc28e5c40..a108c9752909 100644
--- a/net-p2p/amule/amule-9999.ebuild
+++ b/net-p2p/amule/amule-9999.ebuild
@@ -27,6 +27,7 @@ RDEPEND="
dev-libs/boost:=
dev-libs/crypto++:=
sys-libs/binutils-libs:0=
+ sys-libs/readline:0=
sys-libs/zlib
>=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X?]
daemon? ( acct-user/amule )
@@ -42,8 +43,10 @@ RDEPEND="
DEPEND="${RDEPEND}
X? ( dev-util/desktop-file-utils )
"
-BDEPEND="virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
PATCHES=(
)
@@ -55,7 +58,7 @@ pkg_setup() {
src_prepare() {
default
- if [[ "${PV}" == *9999 ]]; then
+ if [[ ${PV} == 9999 ]]; then
./autogen.sh || die
fi
}