summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-05-24 00:46:49 +0200
committerLouis Sautier <sbraz@gentoo.org>2023-05-24 01:10:42 +0200
commit9824d7b563c47cec788df39b8504840eb31abbcc (patch)
treed64473c6784eaba0affd700b924ef1e0011631f5 /net-p2p
parentsci-libs/trilinos: disable complex double/float variants (diff)
downloadgentoo-9824d7b563c47cec788df39b8504840eb31abbcc.tar.gz
gentoo-9824d7b563c47cec788df39b8504840eb31abbcc.tar.bz2
gentoo-9824d7b563c47cec788df39b8504840eb31abbcc.zip
net-p2p/airdcpp-webclient: add 2.12.1, support Python 3.12
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 9e615f35f8e2..f075e2273621 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,3 +1,4 @@
DIST airdcpp-webclient-2.11.2.tar.gz 978294 BLAKE2B cb15e02dc5381cc5f0ecb1b4d65cdd1c4a3d007f3ea1e78a159b8a62af03831318b8f6d8c0692c5a9145dda616627ea97f4bd3eeb1270a7452c7d78bf01d147f SHA512 281d4a9da88f23a4c02eef7f09c4fc2c91c44ac93d932ea4bfe097029b45dbd12a8d04d4ef8b493d261f5dade15b62ed4d564197fbfb2d9d98b9dfcc9a9e6379
DIST airdcpp-webclient-2.11.3.tar.gz 957277 BLAKE2B fd80433e6c8138c4f60758e4813a056a59586b4f51048a7b717114781fa7b11e5ef0a4cf4fee8441bce6bebc3889acd0ae597c07850da50776454d9ba8230f19 SHA512 59b6189021411fdd3c75ec4744fdb03eb6e6b39b08c1ca9da9519998546a5be5218b4ff2eea7f2d3894fd9146693e807d2cc2396f0f03c074f45cbb4403fe326
DIST airdcpp-webclient-2.11.4.tar.gz 958611 BLAKE2B f0ff3a39c8615edbc541a952460b831eefd37f1825da4881da147c54a00612479382a9d69d4399f55fbdd77c77ab6716097594c8d10c6a3839db5ae14d11cc87 SHA512 0ab8fbdc6d1b815546724bfdcd436aa2e07ffdb499b91a3506db18c2f494f76bc1203d0d9d3cfd3ae6ad9d0f2fb4038df46aada0515747e2477c7f6595a05436
+DIST airdcpp-webclient-2.12.1.tar.gz 961603 BLAKE2B bc17fb3b3643b1d699f7c0ef958616759d87cd96467318a592c1460e355d512a3efc0e793a3098f8074f02d5af47b1ef33b65fbe7a6c9a955bbdc472d323f637 SHA512 0f662311d208b937c946b41a617c82a0e72442fb7c2bef09d56ec71931bde35bd1024ce53cb3bf7deda3eaaac31ecbe8fa2c66c337c0833db655f80f5e5156be
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild
new file mode 100644
index 000000000000..a0c2b11391c2
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~riscv ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist(-)]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}